How to limit hours available to just working hours?

For some reason my calendar shows 24 hours worth of appointment slots. I dont want the customer to be able to schedule an appointment at 2am and would prefer times only between 9-6 show up.

  • Rupok

    Hi David, hope you had a wonderful day.

    For doing that, you need to specify your calendar to any specific worker. For example, on my test site, I've set the following shortcode:

    [app_schedule worker="1"]
    [app_confirmation]

    So it will show the calendar for Service Provider 1. Now I set working hour for SP1 as the following image:

    And in front-end, I get this:

    It's only showing working hours available. The key point is the "worker" parameter in shortcode.

    Please let us know if it's still not working on your site. We will be glad to investigate further.

    Have a nice day. Cheers!
    Rupok

  • David

    Thanks for the reply. So I tried adding it and it didnt change anything. I created a test page at
    http://app.convectek.com/test/ with just the shortcodes you'd mentioned above and nothing else.

    [app_schedule worker="1"]
    [app_confirmation]

    i changed your "1" to "4" who is service provider listed in my workers table. That made it so the calendar wouldn't even load. So I adjusted the encoded quotes for real quotes and the calendar shows up again but still with 24hrs of dates.

    [app_schedule worker="3"]
    [app_confirmation]

    I tried with no quotes too just for kicks but it didn't help.

    Oh and yes I've verified that the worker/service provider has his hours set correctly like you mentioned.

    I've enabled the support access btw.

    Your help is very much appreciated.
    Thanks!

  • Nithin

    Hi David,

    Hope you are doing good today. :slight_smile:

    I checked your website, and on further testing it seems the issue is with the custom Time format set under General > Settings.

    Adding seconds is causing this issue, it works with H:i, or G:i. I will have to ping the developer regarding this, and ask whether this is a default behavior of the plugin, or not. Will keep you updated regarding this, once I get a response.

    Current workaround would be, to use the H:i or G:i, as the time format.

    I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.