How to make appear Facebook comments and to moderate them on my website ?

Hi,

I just got your Pack and Installed Utlimate Facebook.

My goal is :
.1. to allow regular visitors to post some comments on my posts
(like Facebook Comments plugin as I dont have on my website some register page or request to register regular visitors)
2. to be able to moderate Facebook post if needed (kind of moderator view like on your vidéo tutorial or a page i can see all comments and moderate them).
Please help about these 2 above

I am very beginner in php and not coding so i need to use plugin and boxcheck as most as possible.

3. Actually on my post page, even i uncheck theme or wordpress regular comments, a comment box is there and i not the kind of Facebook comment one (with plugin Facebook Comments),
So, help me to set up correctly.

Big thank,
Olivier Guérin

  • Tyler Postle

    Hey Olivier,

    Hope you're doing well today! Welcome to the WPMU DEV Community :slight_smile:

    Thanks for granting support access - it doesn't look like you have installed Ultimate Facebook yet though? Unless it's on a different site. You can install it straight from the WPMU DEV Dashboard via:

    WPMU DEV > Plugins then search for it and click the install button.

    We have an awesome usage guide on it as well: https://premium.wpmudev.org/project/ultimate-facebook/#usage

    When you are logged into Facebook and viewing your comments you will be able to moderate them from the frontend.

    We have a video tutorial on setting up the comments too: https://youtu.be/42UfDHIU9ZA

    You can view the full Ultimate Facebook video tutorial playlist here: https://www.youtube.com/playlist?list=PLV1BcivFAIdtOy-6iY4Da_9Ol1qV5xPj4

    If you still have further questions after that then just let us know and we'll be more than happy to help!

    Look forward to hearing back :slight_smile:

    Cheers,
    Tyler

  • Tyler Postle

    Hey Olivier,

    Thanks for your reply!

    This is likely a incompatibility with your theme. It probably doesn't use WP standards when it comes to the comments, so Ultimate Facebook isn't able to find the correct hook.

    No problem though, there is ways around this :slight_smile: If you know which hook your theme uses then add it into that bottom field in the comments settings. Otherwise we can just add one as explained in the fine print there. Screenshot attached.

    If you're not sure how to add it then we can help with that. I will need your FTP though so I can access the theme files.

    Can you send me your FTP through our private contact form? https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Since you have granted support access already, the WP admin credentials are optional. It may save us from asking you to re-grant access later on in this ticket though :slight_smile: up to you! We do need the FTP though.

    Look forward to hearing back.

    All the best,
    Tyler

  • Tyler Postle

    Hey Olivier,

    Hope you're doing well today!

    I've just added that hook for you and set it up in the Ultimate Facebook settings, the facebook comment box displays properly now :slight_smile: you can check it out on one of your post pages.

    I added the hook to your comments.php near the top, I made sure to copy the edited file into your child theme too so you don't have to worry about the changes being removed on updates.

    As for the Facebook connect widget issue, is that working in the default 2015 theme? I can check it myself, but just want to make sure you're okay with me temporarily switching your theme.

    Something else you can try is granting extended permissions to Ultimate Facebook, some features will require this. You can do this from the Ultimate Facebook settings as seen in my screenshot.

    Look forward to hearing back!

    Cheers,
    Tyler

  • Olivier

    Hi Tyler,

    Thank you already for getting these Facebook comments.
    Still 2 things :
    1. to be able to moderate them :
    a) 1 by 1 first, I tried by connecting to Facebook too but i cant delete the post i made especially few days ago. So, I would like the moderator view.
    b) to moderate all Facebook posts i will get in near future with the Facebook App feature. I know we can set up that with Facebook app but that request some coding integration. I can get the codes but i dont know how to integrate them.

    2. I extended already permission and i already switched to main them 2015 to try to put widget in blog sidebar. Still not working event with main theme . So, how can you help on this ?

    Thank you

  • Olivier

    Hi Tyler,

    It s moving forward. I can now get a moderator view to the Facebook posts.

    Now, another issue is when i post some facebook comments. The link is ok in Facebook but the image that appears is the one in the Actality Widget and not the image of the post. Is it normal ?

    And how it goes regarding all the widgets features to be able to put them in the blog sidebar if needed ?

    Thank you to give me some updates about this.
    Regards,

  • Tyler Postle

    Hey Olivier,

    Hope you had a good weekend!

    I've fixed the connect widget for you, we just needed to turn on Facebook connect in the settings :slight_smile:

    I've attached a screenshot to illustrate where to set that. Should be all good once you turn that on.

    *I've left it off because I wasn't sure if you wanted "Test" widget active on your site.

    All widgets should work fine on your site, you will just need to make sure you activate the others via: Facebook > Widget Pack - I see you already have most of them active :slight_smile:

    Now, another issue is when i post some facebook comments. The link is ok in Facebook but the image that appears is the one in the Actality Widget and not the image of the post. Is it normal ?

    It's likely grabbing the first image it finds. Is it not taking your featured image either? Try settings a featured image for the post.

    Look forward to hearing back!

    Cheers,
    Tyler

  • Olivier

    Hi Tyler,

    Thank you so much, yup got a great week-end and hope you too.

    I am testing all widgets and looks good.

    Now, still the comments issue :
    Even with featuring in OpenGraph tab for Post a specific image, when i comment the post I see an other image. So, still that to work on please. I guess it will be the last thing.
    U can try too to post a comment then u will see the image in your facebook is not the one featured in post.

    So, help on this please, regards,

  • Olivier

    Hi Tyler,

    I need your help as the web site will be fully live next week. The Comments system with Facebook need to be working as it should, as I have planed a web communication plan with Posts and Facebook professional community.

    So, you did great, i really rely on you to solve this last issue. Users and customers need to see all the correct pictures linked to articles and Posts.

    Thank you to find a way,
    Regards,
    Olivier

  • Tyler Postle

    Hey Olivier,

    Thanks for your reply here. I've been looking further into this and it's looking like still a theme conflict, just to be sure, if you temporarily swap to default 2015 and do a test comment does it show the correct image? UF takes the featured image, but if it can't use the featured image then it finds the first image in the page.

    Do you mind if I temporarily swap themes and test it? Just want ask first to make sure in-case you're working on the site when I test it, so it's not a surprise or anything :stuck_out_tongue:

    Look forward to hearing back!

    All the best,
    Tyler

  • Tyler Postle

    Hey Olivier,

    Thanks for all your patience on this one :slight_smile:

    I've been doing quite a bit of testing on my own site for this too and the comment display on facebook seems to be pretty inconsistent for me. I'm going to flag the developer here so I can work with them further on getting this sorted out for you. We will get to the bottom of this.

    Either myself or the developer will post back here once we have something to report back.

    Talk to you soon!

    Cheers,
    Tyler

  • Olivier

    Tyler,

    You are really great and I appreciate all the energy to put on this. Yes, sometime i am quite impatient but I trust your quality of service and professionalism.
    So, I hope it will go quite fast anyway as mid next week, i need to launch some communication campaign on my new site and professional identity.
    I really appreciate your concern and the involvment on your team. So far you 9/10 quality of service, keep going.

    I will work mainly offline this day and next, so you can test all you need on my admin and site.

    Regards,
    Olivier

  • Tyler Postle

    Hey Olivier,

    Hope you had a great weekend! I spoke with the developer on this and he was able to get it all sorted out :slight_smile:

    Turns out actually that it was due to caching. Turning on open graph and then clearing cache did the trick.

    I've just done another test comment and it worked, I've attached a screenshot to illustrate.

    Hope this helps and let us know if you're having any further issues!

    All the best,
    Tyler

  • Tyler Postle

    Hey Olivier,

    Hope you're doing well today, apologies for the delay!

    I forget which caching plugin you had? or if you had one? It could be just server side too.

    However, if you do have a caching plugin then there will usually be a "clear all caches" or "clear caches" option in there - clicking that will do it.

    Some hosts have custom server side caching setups and will often put a "flush cache" or "clear cache" button in your admin bar.

    If none of that sounds familiar then can you grant support access again :slight_smile: I'll take another look.

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back!

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.