How to reduce page load from 20MB?

Hi,

Whenever I run my site in Pingdom's page load tool, it tells me my site is almost 20MB in size. I have already ran WP Smush and even turned on the Super Smusher. It is still saying my site is 20MB in size. How can I reduce this?

Also, Hummingbird shows a 0 score because it tells me to optimize my images, so I click on to fix it, and it says to configure WP Smush, and so I click on that, and then WP Smush says I have no images to smash

  • Nithin

    Hey Blake,

    Hope you are doing good today. :slight_smile:

    I'm afraid you didn't mention which website you are having issues with so that I could check in Google Page Speed, ,and in Pingdom to have a better idea regarding this issue, neither the support access isn't enabled too.

    Could you please enable support access, so that we could give a closer look at your website configuration. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • apurba_podder

    Hell Blake,

    Sorry for inconvenience .

    I have already ran WP Smush and even turned on the Super Smusher. It is still saying my site is 20MB in size. How can I reduce this?

    Also, Hummingbird shows a 0 score because it tells me to optimize my images, so I click on to fix it

    Smush Pro only compresses images but it doesn't resize your images. Hummingbird suggests you regarding compressing and resizing. Smush Pro compresses your images to the optimum extent. If you compress them more, they will look bad. So to increase performance, you can try resizing them according to the div/region size those images will be used in.

    Suppose your site has a header slider area of 500px width. Now if you use a 1920px image in that slider, it won't be optimum. You should first compress that image and then resize that image to 500px width. You can resize images from your WordPress Dashboard Media section. Please check attached screenshots for reference.

    I could see that image you have used is bigger than necessary. Please resize your image accordingly.

    Screenshot

    Hope your problem will be solved. If you need further assistance please contact us.

    Best Regards
    Apurba

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.