How to remove login/sign up page CoursePress Pro ?

Hi,

Intention : to use a custom sign up & login page using Gravity Forms (registration add on).

i am using the CoursePress theme (version 2) & the newest version of the plugin,
i have unchecked all the "theme menu items" (screenshot attached).
yet still i get a custom login and sign up page.

this makes sense if i assume the above only applies to the menu.

issue is when a user (logged out) visits a course details page and clicks on the big blue "enroll now" button they still get a custom register / login pop up (screenshot attached).

so basically there seems to be an option to uncheck "Use Custom Login Form" but only for the menu, at least this is how it seems to me.

but i want the option to uncheck such a feature completely as mentioned to use Gravity Forms for extra fields such as "interested in becoming an Instructor" etc. etc.

another issue is that the "virtual pages" would still exist,
shall i choose a custom page and use that with Gravity Forms ? my guess is that there may be a conflict which i will test out.

so basically please advise me how to eliminate all the default sign up / login pages and pop ups ; example - have the "enroll now" redirect to my GF page. as well as possible hide virtual pages from any tech savy users etc.

your very kind assistance in this would be greatly appreciated.
kind regards.

  • Rupok

    Hi amused,

    Thanks for asking. Let me describe one by one.

    basically there seems to be an option to uncheck "Use Custom Login Form" but only for the menu, at least this is how it seems to me

    If "Use custom login" box at settings is not checked, it's supposed to disable the popup. But this is not working for my test site too. So I'm confirming this as a bug and reporting our developer right now. I believe, she will come up with a fix very soon.

    Please keep in mind, our developers work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and release a fix. When this fix comes, un-checking this option will disable the popup as expected.

    In the mean time, if you want to disable the popup when users click on the "Enroll Button" and redirect them to your custom login page, then you can do this by creating a MU Plugin. For creating a MU Plugin, create a folder named "mu-plugins" inside your "wp-content" folder. Then inside that "mu-plugins" folder, create a file with any name and with a .php extension. Now paste the code inside that file and save.

    <?php
    add_action( 'wp_footer', 'change_enroll_click_event' );
    function change_enroll_click_event() {
        ?>
        <script type="text/javascript">
          jQuery(document).ready(function() {
            jQuery('.apply-button').click(false).click(function() { window.location.href = "http://premium.wpmudev.org"; });
          });
        </script>
        <?php
    }

    Please replace "http://premium.wpmudev.org" with your target URL.
    For getting more idea on mu plugins, you can go through this article: http://premium.wpmudev.org/manuals/wpmu-manual-2/using-mu-plugins/

    another issue is that the "virtual pages" would still exist,
    shall i choose a custom page and use that with Gravity Forms ?

    You can choose custom pages instead of virtual pages from settings. I've created a custom page with Membership 2 Pro login shortcode, and set that page for CoursePress login page in "Dashboard > CoursePress Pro > Settings > General Settings" section. It worked fine for me without any conflict. And after setting this page, when I tried to access the virtual login page for CoursePress, it redirected me to the custom page I defined for login in CoursePress settings. So when you set custom pages, virtual pages won't be accessible.

    Please let us know if you have any confusion or any further query. We will be glad to help.

    Have a nice day. Cheers!
    Rupok