How to remove/replace default image on every blog post

The blog aggregate page has pulled a default photo (from somewhere) that it uses on every post. The same pixelated picture shows up under the title of every post. I tried going to the template (I think…) and unchecking “featured image” but it’s still there.

How do I get rid of this image, replace it with an image under the titles, and get the aggregate page to pull an image from the actual post?

Thanks.

  • Nastia
    • Support Rock Star

    Hello @prosapien

    I hope you are doing well today!

    I can confirm on my installation that after unchecking the Featured image option in Post Parts setting, has not actually removed the Featured image. I’ve flagged this as a bug to our developers.

    There is a workaround if you wish to completely remove the featured Image from all posts:

    – Open any of your posts in Upfront Edit mode

    – Hover over the Featured Image region, click on Settings

    – Delete the region and save the settings

    – In the Pop Up window you will be asked to save settings only for a specific post or for all post of this type, choose: All Posts of this type

    In the future, if there is a need to add a featured image again, you can add a new region inside the post page, and save the settings by choosing “This Post Only” option.

    I hope this helps!

    Cheers,

    Nastia

  • ProSapien
    • The Crimson Coder

    This did not work for me. When I hover over the featured region image, there is no “settings” button or link or anything else for me to click on.

    This KIND OF worked. At least it lead me to the solution.

    If I click on the Edit pencil in the top/right corner, I get to the background. Then I can click on the gear and chose a different background. Then if I click OK and then Finish Editing Background and then Save in the side panel, I can get the This Post Only or All Posts of This Type choices.

    I have a question though, WHERE is that default background stored? I went to Media Library and removed all the pixelated pictures that were added when I switched themes, but the images remained. Where are they stored?

  • ProSapien
    • The Crimson Coder

    OK, so even that didn't work right. Look at the side-by-side images I've uploaded. One is of the correct hex color as shown in the Upfront backend after I removed the image and put in a solid color background. On the right is how that same background DISPLAYS in the regular blog view. ???

  • ProSapien
    • The Crimson Coder

    Also, even after removing the image that shows up behind the post titles, the pixelated image still shows over EVERY post listed on the blog aggregate page. I can’t understand why this setting exists, as I can’t imagine that anyone would want a list of blog posts with the SAME image repeated again and again. ??? How do I get rid of those images? Where is that image stored? (It’s not in the media library.)

  • Panos
    • SLS

    Hello ProSapien,

    That image you see is stored in a theme’s (child theme’s) folder and it is used as a default image if no featured image has been set for the post. Please let me know if you mean a different image :slight_smile:

    It’s path should be similar to the following for the Luke and Sara theme:

    ../.../wp-content/themes/uf-luke-and-sara/images/single-post/bg-nophoto.jpg

    Regarding the difference in the backgrounds you mentioned, are these screenshots on the same browser? The theme has little to do for this, it simply provides CSS for the styling and then it is up to each browser to display the hex colors etc.

    Hope this helps!

    Kind regards,

    Panos

  • ProSapien
    • The Crimson Coder

    Yes, it's the same browser. The only difference is that one is in the Upfront backend the other is on the site as a user sees it.

    This occurs in both Chrome and Safari. I'll upload a screenshot of Safari in this comment. It also has another artifact (in Safari) that you can see. A number of the templates have a tiled background image (that causes those stripes) that I have to go in and remove.

  • Nastia
    • Support Rock Star

    Hello @prosapien

    I trust you are doing well today!

    Per the default image when no feature image is selected, how do I set it so there is no default image at all?

    After some troubleshooting here is the workaround to hide the featured image from the blog posts list:

    – Open the News menu on the Upfront Edit mode

    – Click on Settings > Apperance > Create New Preset

    – Go to Post Parts Settings and Unceck The Featured Image Option

    Here is the screencast:

    https://monosnap.com/file/uPNNMFsgzksc5wrIpbt3N2mUYYgOWr

    This way there will be no Featured images shown on the blog list at all.

    As for the issue with the color, would you please grant support access from your Dashboard > WPMU DEV > Support so that I can check?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,

    Nastia

  • Nastia
    • Support Rock Star

    Hello @prosapien

    There is a CSS code with black background color added to the region container:

    .upfront-region-container-feat-image .upfront-region-container-bg {
    background: black;}

    I could not find its location, so I added the following CSS code to custom theme CSS rules. The background color is back to normal again:

    .upfront-region-container-feat-image .upfront-region-container-bg:before {
    background:none;}

    Let us know if you require any further assistance!

    Cheers,

    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.