How to set working hours for exception days

Hello,

I joined the live chat this morning and spoke with “Arnold” about this issue. I’ve set a few exception working days but the available working hours show up as 8am-8pm. I need to know how to change this. I already set the working hours to 10am-3pm but selected Saturday as a non-working day. This still didn’t help.

So, Arnold suggested that I update my settings to make Saturday a working day, and then set all of the Saturdays that I don’t want to work in the Exceptional NON working days configuration. Even though my working hours are set to 10am-3pm on Saturday they still show up as 8am-8pm on the Appointments calendar. Is this a bug?

Thank you!

-Justin Rogers

  • Timothy
    • Chief Pigeon

    Hey there.

    I was just testing and it seems ok to me. Are you setting the exception for the right service provider?

    I've included a screenshot of my setup showing that I made an exception for a service provider and that it's greyed out on the service providers page.

    If I misunderstand then please clarify further.

    Thanks.

  • justin_rogers
    • New Recruit

    Hello, thanks for the reply. I did find that out after I posted that I wasn’t selecting a service provider so that helped.

    However, I would rather set my Exceptional working days to the 5 Saturdays that are available to take appointments (and set the 10am-3pm time) rather than setting Saturday as a working day and then choosing all of the Saturdays that are NOT available to accept appointments. Is this possible?

    Again, I did get it to successfully work by setting Saturday as a working day from 10am-3pm but I had to select every Saturday that I am not working on the calendar. It would be much easier to just choose the 5 Saturdays that I will be working. Is this possible to do and have the time be 10am-3pm?

    Thanks for the quick reply!

    -JR

  • Hakan
    • The Incredible Smush

    Hi,

    Again, I did get it to successfully work by setting Saturday as a working day from 10am-3pm but I had to select every Saturday that I am not working on the calendar. It would be much easier to just choose the 5 Saturdays that I will be working. Is this possible to do and have the time be 10am-3pm?

    Set Saturday working hours as 10am-3pm and select “Working?” setting as NO (It means you are not working on Saturdays).

    Then enter those 5 Saturdays in exceptional working days field for BOTH ‘No specific provider’ (it means ‘business’ is open) PLUS your service provider (it means somebody is working).

    Then you should be seeing free slots for 10am-3pm for those 5 Saturdays.

    Cheers,

    Hakan

  • aristath
    • Recruit

    Hiya, just going through some of the older threads here.

    As it’s been a little while since we last heard from you I thought I’d check in to see how you’re going?

    If you’re still looking for some further assistance with this thread then please feel free to reopen the thread or of course for any new and related issues you are most welcome to open a new thread.

    Thanks.

    Ari.

  • Joseph Clanton
    • New Recruit

    I am experiencing they same problem. When creating exception days that are available it doesn’t adhere to the time slots of the non working days and post time slots from 8 am to 6pm. I will will use the work around that OP used but i was wondering if there was a configuration setting i was missing.

  • Timothy
    • Chief Pigeon

    Hey there.

    Thanks for posting in this thread, however it might be best if you open your own, even if the issues seem closely related. That way it will remain independent of this one and ensure it doesn’t confuse issues here if this thread needs reopening again by the author.

    It also means the member who started this thread or anyone following it isn’t inundated with post notifications each time we respond to each other. A lengthy thread could annoy the original

    This also allows us to better track and answer your questions to ensure we don’t miss any for ya.

    You can start a new thread here:

    https://premium.wpmudev.org/qanda/

    Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.