How to setup Google Calendar

Hi,

I have been trying to setup Google Calendar in Appointments+ but the instructions in the settings are rather limited. I have found a WPMU video but that shows a screen that I do not have, probably an older version:

https://www.youtube.com/watch?annotation_id=annotation_910827&feature=iv&src_vid=hul60oJ1Eiw&v=Uh-K-6Sxu3I

I've searched for a post on the support forum but there are 50 pages found no matter what search query I use. Can you please help me set it up? A link to up to date instructions, including what to do on the Google side of things would be great too!

The idea is to setup the calendar so that Appointments+ does not allow clients to book on dates and times that are "busy" in Google calendar.

Thanks!
Syl

  • Rupok

    Hi Syl,

    Can you please help me set it up? A link to up to date instructions, including what to do on the Google side of things would be great too!

    Thanks for asking. Actually, Google keeps changing their API interface. So it's kinda tough to cope up with their speed. Most of the things stay same, but their position on screen changes.

    However, I've created a series of screenshots showing what to do that what to click. At first, you will need to go to "Dashboard > Appointments > Settings > Google Calendar" section. Then click on the link provided on that page to create the project. After creating the project, please follow these screenshots:




    After doing all these, it will show you a popup with two keys. Copy those and paste in Appointments Google Calendar settings page and follow the instructions shown after entering these two keys. That will do. After configuring Google Calendar API, make the settings as you need on that Appointments Google Calendar Settings page.

    Please let us know if you still have any confusion or if you have any further query. We will be glad to help.

    P.S. I found that you are using an older version of Appointments+ on your site. Please keep all your plugins and themes updated always because each update comes with bug fixes and feature updates.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi Syl,

    I had blocked a certain time frame on a day in my calendar but was able to book at that time for hours afterwards

    So sorry to hear the inconvenience. Can you please tell us how did you block that certain timeframe on your calendar? Can you please tell us step by step guide to regenerate this issue on our test site?

    Please send us as many details as possible. We will report this to our developer as soon as we can regenerate this on our end.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi Syl,

    Sync should happen once the appointments are confirmed. Maybe one of the plugins are causing conflicts, could you please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Is this a live site? If you still have issues even after running a plugin conflict, could you please enable support access, so that we could have test with our Gcal credentials, and see how that goes?

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please do let us know once you enable support access, have a nice day. :slight_smile:

    Best Regards,
    Nithin

  • Nithin

    Hi Syl,

    Were you able to perform plugin conflict test? How did that go? Not sure I'm checking the correct website, but I could see Appointments+ version 2.0.0 installed in your website(fsn.wpwebxxxxxx.net).

    Would recommend you to update the plugin to the latest version, ie v2.0.5, and then perform conflict test, if you still notice issues.

    Please let us know how that goes, have a nice day. :slight_smile:

    Best Regards,
    Nithin

  • Syl

    Hi,

    - Updated Appointments to the latest version
    - Disabled all plugins but Appointments * (see below)
    - Working Hours in Appointments on Wednesdays are from 09:30 to 03:00.
    - I've setup Google Calendar "Test FSN" to be used for Appointments and selected the A+ <-> GCal setting. See screenshot: https://screencast.com/t/jLTQJ29u
    - I blocked Wednesday May 3 from 09:00 to 4:00pm in my Google calendar. See video: https://screencast.com/t/9LjRkB0P0a
    - I then looked up that Wednesday in Appointments but the all time slots that are blocked in Google Calendar were all bookable by Appointments. See video: https://screencast.com/t/znGBwMEU4Ov

    - Confirmed Appointments are synced to Google Calendar immediately.

    It may very well be that the sync will be done in a few hours, but of course I would want it to be instantaniously. Just like confirmed meetings booked with Appointments through the site are immediately synced to my Google Calendar. At the moment of writing, over 30 minutes has passed and the sync did not yet occur.

    * This same issue occurs when I disable all my other plugins. One plugin I can't disable, because my theme needs it to work: Live Composer. However, I also checked the issue with default WP theme Twenty Sixteen, with all plugins but Appointments itself switched off: same issue. See screenshot: https://screencast.com/t/ZDmnpWyxJqN

    Hope you guys can help.
    Thanks!
    Syl

  • Nithin

    Hey Syl,

    Hope you are doing good today. :slight_smile:

    Thank you for explaining further, it does take some time(upto 10 mins) for the appointment to get synced from Google Calendar to Appointments+ plugin. The scheduled cron job related to sync will take about 10 minutes.

    I tested this in my system, and it took about 10 mins in my system on multiple tests performed, but it can vary. However since it didn't work for you even after 30 mins to 2 hours, it's pretty odd.

    As a workaround, you can force import, by adding the following URL in your browsers address bar:
    yourwebsiteURL.com/wp-admin/admin.php?page=appointments&gcal-sync-now=true

    If the sync doesn't work even after forcing then it's an issue related to how it's booked in Gcal. If the sync does work, then you can check the cron job by installing a Cron Job monitor plugin like:
    https://wordpress.org/plugins/wp-crontrol/

    Once done, you can check the following events appointments_gcal_sync under Tools > Cron Events this should give you a better idea regarding when the next schedule is meant to run.

    Please let us know how that goes, so that we could give a closer look. Have a nice day. :slight_smile:

    Best Regards,
    Nithin