how to solve these?

hi there,
i have a couple of issues on the site i'm working on:
1. 'currently powering ... blogs' doesn't seem to update. how long does it take to cache it? does it make any difference whether the buddypress is activated or deactivated?

2. while trying to register a new site (my main site is using the edublogs theme) as a new client, i'm redirected to /register (i have the buddypress activated on the main site).
A. unfortunately, it doesn't show language dropdown (it does on wp-signup.php when the buddypress is deactivated).
B. i'm using 'set password at signup' plugin together with 'remove email notification', but once i click 'complete sign up', it shows a message with auto-generated password and i get an email with authentication link.
it also show's this message:

Sign Up Complete!

You have successfully created your account! To begin using this site you will need to activate your account via the email we have just sent to your address.

it seems to be ok when the buddypress is deactivated!

C. can i have the registration page /register full width instead? at the moment it's using a member widget and it seems to be no option to have it full width. ideally, i'd like it to be with 3 steps as it is on edublogs..;]

D. it says Blog Details and Blog URL (required).. how can i change this text so it's: Website Details, Website URL?
thanks for your help!!
Adam

  • Kimberly

    Hi Adam! Welcome to the WPMUdev Community!

    I will answer inline so we don't miss anything :slight_smile:

    1. Have you tried clearing your cache and refreshing the page? It shouldn't need anything special to work.

    2. A. Are you using our Wordpress Languages plugin for this?

    B. You probably can do away with the select password at signup and stick with the no email plugin. Your users can change their password at any time after they login initially. can you try with just the no email required plugin and let me know if you still get the email? just to see if it's a conflict issue.

    C. Have you tried to change the page template in your page settings? This is usually the easiest way.

    D. I'm pretty sure you have to get into the core for this one, although I'm not sure, so I will look into it a bit more

    Best,

    Kimberly

  • adam007

    hi Kimberly,
    thanks for your answers.
    1. sure i did clear the cache. it's ok now.
    2. A. YES. like i've written, the language dropdown works ok when the buddypress is disabled. it still doesn't show up when the BP is activated.
    B. i've deactivated 'set password..' plugin and still after completing the sign-up it shows a message with the auto generated password. then i've deactivated all the other plugins except buddypress and still the same so i assume there's some conflict with the buddypress? PS. when i've deactivated buddypress but had both 'remove email' and 'set password' plugins activated, i was able to set a password it it all worked fine. but i need BP as well
    C. i did, it didn't work:disappointed:
    D. i know i can go into the core, but i was just wondering maybe there's an easier way of doing it..

    thanks,
    Adam

  • Kimberly

    2.

    A. I checked the plugin file and do not see that it is compatible with Buddypress. The reason for this is because Buddypress uses it's own registration process and the plugin is made to work with Wordpress registration. I am looking into this though to see if there is anything more to it

    B. BuddyPress by default lets you choose password at sign-up and you don't need this plugin for it to work. Disable the plugin and check the register page, the password fields would still be there.

    C. Check here /wp-content/plugins/buddypress/bp-themes/bp-default/registration
    you will probably have to remove the sidebar from the registration theme file

    D. Some quick checking about and I can't find any easy way to change this, sorry

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.