How to Stop Email Spam by Multisite

Hi,

I wanted to do two things to the sign up process.

1. All Emails should "NOT" Land in Spam folder.

Currently the welcome mail,activation mail and further automessage mail almost everything from my site lands in Spam folder.

I tried your ultimate Branding Email From option and set it as "no-reply@mysitte.com.

I have one Email Id hosted with Google Apps and MX records are changed to Google.
But on the welcome mail, it shows mailed by "gator4188.hostgator.com" This is making the Email to Land in Spam.

Please help me to deliver the Emails in Primary mail box.

2. How do I customize the Welcome mail and Automessage Design (Currently it is plain Mail without any design)

  • aristath

    Hello again @Aathithyan,

    This is probably because of your server's configuration.
    My advise would be to use a 3rd-party service to send your emails...
    You can sign-up for a free account on http://mandrill.com/
    Once you have your free account there, install and configure this plugin on your site: https://wordpress.org/plugins/wpmandrill/

    This will use mailchimp's servers to send your emails, and does its best to prevent your emails from being marked as spam.

    Mandrill gives you 12000 free emails/month which should be more than enough for most use cases. :slight_smile:

    I hope that helps!

    Cheers,
    Ari.

  • CatMan

    Yes I get notifications when user sign up for a site. The Email Address I use is hosted with Google Apps and not by Hostgator default Email Program.

    I am attaching you a copy of the Mail that Lands in Spam Folder. Take a look at it. Help me to Solve this problem.If Welcome Emails and follow up Mails from automessage lands in Spam folder it will cause a serious negative impression on our Brand.

  • CatMan

    I solved this problem. What I did is,

    1. Removed all MX records which were entered to point it to Google.

    2. Created an new email from cpanel.

    3. Logged into one of my Gmail Address. Then clicked settings - Accounts and Import - Add another email address you own

    4. A window opens. Filled the required details. (Mainly Filled the SMTP port)

    5. Now everything is good. All my mails from network are landing in inbox.

    But,

    I will not be able to use Google Apps :slight_frown:

    And Mailed by still shows - gator4188.hostgator.com

    I would be happy to remove that mailed by gator...

    Please help me.

  • Tyler Postle

    Hey Aathithyan,

    Hope you're doing well today!

    Glad the email is landing in the non-spam folder now :slight_smile:

    As for getting rid of the gator4188.hostgator.com, did you try using Ari's suggestion? https://wordpress.org/plugins/wpmandrill/

    I just set it up, it takes only a minute to do and then your mail will send via a .mandrillapp.com address instead of hostgator.

    Personally, I think the mandrillapp.com one looks more professional.

    Hope this helps! Let us know if you need any further assistance.

    All the best,
    Tyler

  • Jose

    Hi there @Aathithyan,

    Hope you are doing fantastic today :slight_smile:

    I see a confustion here regarding MX records.

    The MX record in your DNS server will route any incoming request for SMTP connections to the delagated server, in this case google.
    This means that the MX records will take care of routing the incoming mails to google.

    If you remove those records, the incoming email will go to hostagator servers.

    Now, for outgoing emails you will need to explictly connect to Gmail SMTP servers.
    If you are not using a SMTP plugin in your WP install, it will send emails through the library phpmailer, which will use the MT Agent from your server (hostgator). That expains why your emails are sent from gator4188.hostgator.com no matter what MX records you use.

    Steps to configure Gmail:
    1 - Rollback your MX records to Gmail. (in order to handle the incoming emails in Gmail).
    2 - Install a SMTP plugin like this https://wordpress.org/plugins/easy-wp-smtp/ or similar.
    3 - Configure your Gmail login information in the SMTP settings. (see attached image).

    Please let me know if it works fine for your. We are here to help :slight_smile:

    Cheers,
    Jose

  • CatMan

    Hi,

    I tried Your solution. It Works Great for the main site and for all transactional Emails. Now Emails are being sent using Google Apps.

    But,
    The sub-site using Subscribe by Email throws the following error after clicking submit button.

    Fatal error: Uncaught exception 'phpmailerException' with message 'Invalid address: ' in /home4/aathi/public_html/wp-includes/class-phpmailer.php:797 Stack trace: #0 /home4/aathi/public_html/wp-content/plugins/easy-wp-smtp/easy-wp-smtp.php(131): PHPMailer->setFrom(NULL, NULL) #1 [internal function]: swpsmtp_init_smtp(Object(PHPMailer)) #2 /home4/aathi/public_html/wp-includes/plugin.php(571): call_user_func_array('swpsmtp_init_sm...', Array) #3 /home4/aathi/public_html/wp-includes/pluggable.php(519): do_action_ref_array('phpmailer_init', Array) #4 /home4/aathi/public_html/wp-content/plugins/subscribe-by-email/inc/mail-templates/confirmation-mail-template.php(115): wp_mail('profileblogger4...', 'Please confirm ...', '\t\t<div style="f...') #5 /home4/aathi/public_html/wp-content/plugins/subscribe-by-email/subscribe-by-email.php(374): Incsub_Subscribe_By_Email_Confirmation_Template->send_mail() #6 /home4/aathi/public_html/wp-content/plugins/subscribe-by-email/inc/helpers/subscriber-helpers.php(131): Incsub_Subscribe_By_Email: in /home4/aathi/public_html/wp-includes/class-phpmailer.php on line 797

    How could I deal with this now?

    Also,

    The link here says,

    " Gmail's SMTP comes with severe sending limits in order to prevent spammers from using its outgoing server to blast out garbage emails. The boundary is 100 recipients a time and 500 messages per day: if you cross this restriction, Google will block your account."

    Is that true? If yes, I understood that to deliver the Emails In Inbox I must use Mandrill App only.

    My aim is to deliver all the Emails in Inbox and the users n sub-sites using subscribe by Email plugin also should be able to deliver Email in Inbox. That's it. (After putting all hard work no one wish to land their Email on Spam folder right.)

    Please Advice.

  • Jose

    Hi @Aathithyan,

    Regarding Gmail SMTP limits, you can see the official information here:
    https://suppdiort.google.com/a/answer/166852?hl=en

    If you need to send more than 2000 mails per day, you will need to look for alternatives.

    If the problem is the amount of recipients per message, that wouldn't be a problem since you can set "Mail batches" limit in your site settings. (see image 2).

    In regard to the php error, I just ran some tests on my own install and everything seems to work fine between Easy WP SMTP and Subscribe by Email.

    Can you please confirm if the error occurrs also when you try sending a test email from Subscriptions->Settings->Mail Templates "Send a test mail to:"? (see image).

    Are you using any ther plugin that might be messing with email handling?

    Please advise.

    Cheers,
    Jose

  • CatMan

    Hi,

    I just rolled back from using Google Apps since I should pay for extra Email Ids in case need to be added.

    And rolling back doesn't cause any issue. Now Emails from main site are landing in Inbox.

    There is just one problem to solve.

    I tested subscribe by Email from a test site in my network. My network is based on Sub-domain Install.

    The emails from this test site are landing in spam folder only. I will attach the Email Info with this post.

    My users are not happy with this plugin which is delivering their emails on spam folder to their subscribers. I personally replied them to solve this problem as quick as possible. Please help me.

  • Tyler Postle

    Hey Aathithyan,

    Hope you're doing well today!

    The emails landing in the spam folder has nothing to do with the plugin itself and more to do with the content inside the email and the server that is sending it.

    If whatever email service that is receiving the email, deems the subject/content/sending server as spammy then it will mark it as spam.

    Assuming your content is fine, then it's likely the hostgator sending server, this is why I would recommend using Mandrill, it's the same people that do Mailchimp - so they have very trusted mailing servers.

    Which steps were you confused with when trying to install wp mandrill? You should only need to sign up with a free mandrill account then copy and paste your api key in :slight_smile:

    Look forward to hearing back!

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.