How to stop loading screen after form is submitted

Hi, I have created a popup which contains a form that submits via ajax. When I send the form, the popup shows a loading screen. But after the form is sent, the loading screen never stops. The popup keeps "loading" forever.

I think it has to do with this setting: but I already tried all the options with no luck.
https://docs.google.com/file/d/0B6nmyp5p7PnYOGhkQkpjQ1EzZ2M/edit?usp=drivesdk

  • Vinod Dalvi
    • WP Unicorn

    Hi Jose,

    Thank you for your another question today.

    Could you please share me the page URL where you are displaying the pop up having the form so that i can test it?

    Also would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Vinod Dalvi

  • Jose Vega
    • Design Lord, Child of Thor

    I just gave you access. But you need to do the following steps to be able to access the site because it´s a dev site.

    1- connect the domain to the ip 181.224.145.182
    2- when you go to the website, you´ll need to authenticate with apache using.
    Username: Admin2947
    Password: 24472820

    After this, you can log in to the site as usual.
    Here´s a little video of the issue:

    This is what I´ve done: http://youtu.be/w9JYU7dkprA
    1- I created a popup which opens when I click a custom button.
    2- The popup contains a shortcode from a plugin to save post on collections. If I save the post to an existing collection, which doesnt involve a form, it works fine. But if I try to add a new collection, i get the loading screen on the popup even though the collection was already added.

    In the video I remove the class wdpu-loading from the dom using chrome inspector and the loading screen stops, and I see the collection was created.

    So basically I just need to disable the loading screen on the popup. There´s nothing wrong with the collections shortcode because it adds the collection properly. It´s the popup that never stops "loading".

    PD. You can see the issue when clicking the button I show in the video in any post on the front end...

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.