How to test where your mail is being sent from?

I am using the Subscribe by Email plugin and I have WP SMTP plugin setup to use our SMTP server to send all of our emails. We originally had it setup through SendGrid but had negative results as their IP addresses are listed on a bunch of spam block websites.

With that, I'm not sure our mail is being routed through our SMTP server and not sure where to check that it's being done.

Secondly, with the plugin "Subscribe by Email" it's knocking my server offline when I publish a post to "Subscribe by email" and it sends out to our thousands of subscribers. I'm not sure if this is because the server is trying to use PHP mail to send? But I'm also not sure how to check that.

Any help would be greatly appreciated. Also, how do I force it to use the WP SMTP plugin?

Thanks,
David

  • Nithin

    Hi David,

    Hope you are doing good today. :slight_smile:

    With that, I'm not sure our mail is being routed through our SMTP server and not sure where to check that it's being done.

    Please send email into your inbox, and then check in that which email is defined in the From: address section of that email. If SMTP is working fine, it should show the email configured via the SMTP.

    You might find the following article helpful too:
    https://sendgrid.com/docs/Classroom/Troubleshooting/Authentication/how_do_i_check_the_headers_raw_source_of_an_email.html

    You can use a plugin like Check Email to send test emails:
    https://wordpress.org/plugins/check-email/

    Secondly, with the plugin "Subscribe by Email" it's knocking my server offline when I publish a post to "Subscribe by email" and it sends out to our thousands of subscribers. I'm not sure if this is because the server is trying to use PHP mail to send? But I'm also not sure how to check that.

    Maybe you are running out of memory limit, you can check your current memory limit, under WPMU DEV Dashboard > Support > System Info

    If it's low, you can increase your memory limit, you'll have to create a php.ini file inside your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 180

    If you aren't able to increase your memory limit, would recommend you to get in touch with your host, in order to increase these values.

    Please check this link for more info:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Any help would be greatly appreciated. Also, how do I force it to use the WP SMTP plugin?

    If you are using SMTP plugin, it should be sending emails via SMTP, unless another plugin is changing this setting. Subscribe by Email doesn't such settings, it'll only try to send emails on how WordPress is configured ie via PHP mail, or via an SMTP plugin. Is there any instance that's making your doubt regarding the SMPT isn't working?

    I hope this should help resolve this, if not, and you still have issues, please do enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.