How to turn comments off?

Greetings!

I am out of luck! I've spent an hour trying to find an answer to turn the comment off in my "About Us", "Contact Us" and other web pages. I did try to look into Wordpress settings. I know I've saw it before but now it's not there. I wonder why? Is it because the theme I bought from here that changed the templates? I even tried to install several pages templates to see if it would work but no.

Your help is greatly appreciated.

Best,

Brad

  • marikamitsos
    • The Crimson Coder

    Hello bapjo4 and welcome to WPMUDEV forums,

    It is right there under Discussion on your Edit screen. If you don't see it , then it means you have to go to the top right of your screen and click on Scren options to make the particular option visible.

    I hope that helps
    marikamitsos

  • aecnu
    • WP Unicorn

    Greetings Brad,

    Turning off comments is not a theme function, so therefore it is not because of the theme or at least not that I have ever heard of.

    To turn off comments logged in as site admin go to --> Settings --> Discussion --> Default article settings section --> Un-check --> Allow people to post comments on new articles (see screen shot below)

    Please advise that this has worked out for you or not.

    Cheers, Joe

  • marikamitsos
    • The Crimson Coder

    @ bapjo4
    I think I need to clarify things a bit so you don't get confused.
    Joe is absolutely right if you want to disable comments posting for your entire site (posts and pages).
    On the other hand I took a slightly different approach. Did you notice (on Joe's screenshot) the small prints (These settings may be overridden for individual articles.)?
    That is what I was referring to.
    So...

    I've spent an hour trying to find an answer to turn the comment off in my "About Us", "Contact Us" and other web pages.

    If you want to disable for the whole site you follow Joe's suggestion.

    @Joe. Thanks for helping out. :slight_smile:

    I hope that helps. Please let us know how you do.
    Thank you for your time,
    marikamitsos.

    Should you find the provided solution satisfactory, please mark the topic as resolved.
    Thanks again, marikamitsos

  • Bradley
    • Flash Drive

    Hi Joe and Marikamitsos,

    Sorry if I didn't explain that in details from the previous post but I did go to Settings ---> Discussion ---> Default Article Settings to have it unchecked. I didn't see the comment box go away. I had to check it again then unchecked it to see if it's finally off. Apparently, the comment or Leave A Reply box seems to be stuck here! I really want to turn it off.

    Do you think that plugins have to do with that?

    Brad

  • marikamitsos
    • The Crimson Coder

    the comment or Leave A Reply box seems to be stuck here!

    I assume you are talking about the comments box on the front of your site.

    go to the top right of your screen and click on Scren options to make the particular option visible.

    Have you done that? If so, please uncheck the "Allow comments box" on the edit screen of a specific page/post and see what happens. Is the box (on the front) still there?

    Do you think that plugins have to do with that?

    Can you please list the plugins you have activated?

    Do let us know what is happening.
    marikamitsos

  • aecnu
    • WP Unicorn

    Greetings bapjo4,

    Is there any chance you are running a caching plugin?

    If so this could very well explain why you are having the mixed results that it appears you are currently getting.

    Marikamitsos is also correct that if they are turned on post per post they would stay on even when turning them off in the main section.

    Please advise.

    Cheers, Joe

  • Jonathan
    • The Incredible Code Injector

    You could also deactivate comments on a page by page basis. Hover mouse over page and select quick edit this opens a small edit screen which has comments box ticked. Untick it and hit update.

    Joe is onto something as well if nothing works you might be seeing cached version

  • Bradley
    • Flash Drive

    Gentlemen,

    It could be the cache plugin. I had W3 Total Cache enabled. But anyway, I decided to delete the webpage and put the words back into a new web page. Now it's not showing the comment on the bottom. Weird.

    Many thanks for your help!!! Greatly appreciated. I have some more issues (different one) and will post them later.

    Brad

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.