How to Turn off Comments

I was wondering how to turn off comments on pages - I did so from the Discussion tab under the settings section of the admin panel yet the "Leave a Reply" box still appears like on the page linked to below - please advise as to how to get rid of this section