How to turn off compression for a file?

I’m still having issues with some icons not rendering, and have narrowed it to some of the files being compressed, that I’d like to turn off. I’ve been playing with the settings and files, but there’s one thing I haven’t been able to figure out.

For the files that say ‘This file is already compressed’, how can I turn off compression, and revert it back to the original file (without turning off Hummingbird)?