How to update jQuery? Pls help!

Hello - My site will not load with this new theme, because it says my jQuery is outdated.

The error:
"blockUI requires jQuery v1.3 or Later! You are using v1.10.1"

Can you help me figure out how I update and where I do it? Is it via FTP?

Here is a link: http://spokenpress.com/

I downloaded the jQuery updater plugin, but didn't seem to work.

PLEASE HELP!

Thanks,
Ellie

P.S. Is there a way I can point jQuery link to Google library so it's not looking for my hosted version?