How to upgrade to wmpu 2.8.1 using multidb

I already have version multidb 2.7.5 already installed with wpmu 2.7.1 using 4096 databases. Anyone know an easy way to upgrade wordpress mu version 2.7.1 using multidb to wpmu 2.8.1? Will multidb 2.7.5 compatible with wpmu 2.8.1?

Please help me figure out how to backup the huge number of databases (4096), or is there an easier way to do this before upgrade?

To my knowledge, when you upgrade anything, u need to backup.

Also, after backing up, what is the next step to upgrade the wpmu, multidb, and if using buddypress?

After upgrade, if things go wrong, what if I want to revert back to wpmu 2.7.1?

To revert back to 2.7.1 if necessary, is it easy as emptying 4096 databases, and then using mysql import to import back 4096 databases? Then use wpmu version 2.7.1 original files and directories? Using the multidb version of 2.7.5 files again, do i need to run move-blogs.php again?

Thanks...

  • Andrew
    • Champion of Loops

    Hiya,

    We haven't tested Multi-DB with WPMU 2.8.1 yet. Mainly because it was released so late in the week.

    That said, I'm not aware of any changes that would result in Multi-DB 2.7.5 not working. However, it's ultimately your call to upgrade now or wait until we have a change to test and release Multi-DB 2.8.

    As for upgrading, there aren't any additional steps really. Just upload the new WPMU files and upgrade the blogs like you typically would.

    As always, make a backup before doing anything.

    Thanks,
    Andrew

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.