Howdy, are your language plugins "Languages for WordPress"

Howdy,
are your language plugins
"Languages for WordPress" and/or
"Select Language At Signup"
compatible with our
-WP V3.6
-Buddypress V1.8.1
-our theme is "BuddyPress Corporate" V1.7.1 --installtion???
Is it necessary to have WP multisite?

Thanks so much for your answer!
Ruediger