hrrp 500 error on uptime monitor

I am getting the following error in defender http 500 server is down. See attached screen shot please.

  • Adam Czajczyk

    Hello Bradley,

    I hope you're well today and thank you for your question!

    The Defender report suggests that you site was getting "downtimes" but I believe you are reporting this because you consider them "false alarms" is that right?

    I checked your site and it looks like there's some "coming soon"/maintenance mode plugin enabled. Those plugins usually cause a redirect that tells uptime monitoring that the site actually is down (it's checking HTTP response statuses).

    In case of your site thought, the initial query from the browser also returns error 500 in browser console so I'd say that there's a bit more "general" issue with the site that would have to be addressed. I tried to access your site using support staff access but I got a message that the "Site admin didn't granted support access".

    This may also be due to aforementioned error. Therefore could you please first try to go to "WPMU DEV -> Support" page and revoke and then re-grant access? Hopefully this will help and I'll be able to access the site. In case it didn't work, I'll let you know about a safe way to provide me with direct access credentials so I could diagnose the issue on your site.

    Best regards,
    Adam

  • Bradley

    I also deactivated all plugins and checked that I have both a wildcard domain entry in apache and dns. Still have that 500 error. I should note that I rebuilt this site already once this week as a result of a similar problem with the Mailchimp and Jetpack Plugins I was having last week. They again don't work again with the same 500 errors.
    As It stands now:
    all plugins disabled at the site network level
    all htaccess files renamed and a new one regenerated for the root site.
    dns and apache wildcards verified.
    access to wpmudev is available.....

    Bradley

  • Dimitris

    Hey there Bradley,

    hope you're having a beautiful day and don't mind me chiming in here! :slight_smile:

    I just inspected your website and I can see that there's only "Mailchimp Sync" and "WPMUDEV Dashboard" plugins activated at the moment. WPMUDEV API also seems to be OK.

    Your site is also available for checking in our wp-checkup page.

    Are you still experiencing this issue in https://premium.wpmudev.org/hub/my-websites/?

    Is there any 500 error that can be reproduced in your backend or/and frontend pages at the moment?

    Please advise!
    Warm regards,
    Dimitris

  • Bradley

    Yes I disabled everything then went out to eat and it was reported as back up. I have been re enabling things as I go. At this point I might be thinking its the defender hardening process and my use of wildcard domains. I usually fix that error by regenerating a .htaccess file with the stand alone version> I am not familiar with having a .htaccess file in several directories. I'll continue to play with it tomorrow. It's been up the whole time but some plugins and the dashboard report the 500 error so I'll let you know what happens .

  • Dimitris

    If you're able to generate an error, then please enable WP_DEBUG so we may have some more intel. You can do so if you access your server via FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);
    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the error once more.
    By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply.

    Have a good one,
    Dimitris :slight_smile: