htaccess Rewrite Help - Failed to load resource: URI Too Long

I have a conflict between two plugins on my website -

a) iTheme Security - An option prevents long string URLs (this is good)
b) OIO Publisher - Uses a long URL strings to load the ads (this is bad)

The security plugin is blocking this specific script. Can I create a rewrite for a specific file that will allow it to load?

The OIO Plugin has a tool for creating rewrites, but it doesn't seem to shorten it enough. It provided the following code:

## OIOpublisher Rewrite
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^adserver/(.+)$ wp-content/plugins/oiopub-direct/$1 [L]

This shortened the code from

From:
/wp-content/plugins/oiopub-direct/js.php#type=banner&align=center&zone=1

To:
/adserver/js.php#type=banner&align=center&zone=1

Initially, the ads loaded once. Now, they are being blocked again. Is there a better rewrite or something else you think may be blocking the ads?

Thanks,
Chris

  • Michael Bissett

    Hey @Chris, hope you're doing well today! :slight_smile:

    It would help to see the URLs for the ads that are being loaded (which would require knowing the site in question), but I get the feeling that the rewrite tool that the OIO Publisher plugin provides may not cover the URLs for the ads themselves. Have you reached out to their support team yet?

    In regards to disabling the "Filter Long URL Strings", a member of iTheme's support staff had this to say:

    All of the features aren't going to be appropriate for all WordPress/server environments. The idea is to enable as many as your environment will allow.

    You may very well need to disable that feature, unless the makers of the OIO Publisher plugin have a workaround available for us.

    Let me know if I can be of further assistance please! :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.