HTML Gzip will not activate

Hummingbird will not allow me to activate HTML Gzip compression. I saw one solution in the Support Forum: adding "php_value zlib.output_compression 1" to the .htacess file. Is this something you can do upon my providing access to my WP?

  • Ashik
    • Staff

    Hi Alan,

    Thank you for your question. Hope you have a great day.

    It seems support access for your site is no longer available right now. I'de like to get support access in order to take a closer look and do further investigation. Please send your site login info as well as Cpanel/FTP info as we may need to work on .htaccess file. Follow this below instructions, please.

    Don't leave your login details on this ticket. Instead, you send us your site details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template is below:

    Subject: "Attn: Ashikur Rahman"

    Site login:
    WordPress admin username -
    WordPress admin password -

    FTP credentials (host/username/password) -
    or
    cPanel credentials (host/username/password) -

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forum. The subject line ensures that it gets assigned to me.

    Please confirm here that you send those credentials

    Feel free to reply here if you've any more questions or concerns. Looking forward to hearing from you.

    Regards,
    Ashik

  • Ashik
    • Staff

    Hi Alan,

    Thank you for your response. I've got your email.

    The result of the investigation is we couldn't enter and work on .htaccess using SFTP login details provided by GoDaddy. It shows an unexpected error while we're trying to login.

    In this stage, I would suggest you contact with GoDaddy support and ask them what's happening with the SFTP login, so we can do any further troubleshoot in future and you too.

    Now, first of all, show GoDaddys support this below screenshot of a suggested method what is showing on Hummingbird Dashboard > Gzip Compression if they can help. Screenshot attached.

    If no luck, ask them to try to enable Gzip compression manually by putting this below code into .htaccess file. The same code you'll get under Dashboard > Hummingbird > Gzip Compression > Enable compression > MANUAL

    <IfModule mod_deflate.c>
    	SetOutputFilter DEFLATE
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-font-opentype" \
                                          "application/x-font-truetype" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "font/otf" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    </IfModule>

    If still no luck try this one what is showing on Dashboard > Hummingbird > Gzip Compression > Enable compression > MANUAL, below the above code. Screenshot attached

    As we weren't able to test by our self, we have to try one by one. Please let us know which one is working for you.

    Feel free to reply here if you have any more questions or concerns. Looking forward to hearing from you.

    Regards,
    Ashik

  • Ashik
    • Staff

    Hi Alan,

    Thank you for your response. Hope you're doing well.

    As your site hosted on WP managed hosting provided by GoDaddy we don't have access to php.ini file that mostly required to enable zlib.compression. Then also we've tried best to solve it from our end but couldn't at the end of the day. Even, the hosting doesn't support custom php.ini too. Currently zlib.compression isn't enabled. Screenshot attached

    So, again we would suggest you to contact GoDaddy support and ask them to enable zlib.compression for you.

    Also, we would suggest you to ask GoDaddy to enable mod_deflate cause Hummingbird giving a possible solution to enable mod_deflate on Humming Dashboard.

    Feel free to reply here if you've any more questions or concerns. Have a great day ahead.

    Regards,
    Ashik

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.