HTML Template killes Links in {MESSAGE}

Hi,

the HTML email templates plug-in does not convert the wordpress links with the {message} tag corretly. It just outputs the link string but does not convert to proper clickable tag.

How can we fix this fast please?

Thanks, Stephan

  • Predrag Dubajic
    • Support

    Hey @Ingenieurbüro Dr. Plesnik GmbH,

    Hope you're doing well today :slight_smile:

    I have tested registration process on your site and it looks like HTML templates are currently disabled, based on the email I received, so I went to test this on my installation and registration confirmation link is clickable on my end, see screenshot attached.

    Could you allow support access so I can do some further tests on your end, and can you include any additional steps I need to follow in order to replicate this?

    To enable support access you can follow this guide here:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,

    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hello @Ingenieurbüro Dr. Plesnik GmbH,

    I hope you’re well today!

    The issue with WPMU DEV Dashboard here is, I suppose, that it has most likely been enabled via another admin-user account. The plugin checks user ID during activation and all its controls are then available only to this particular admin-user that has enabled it.

    That said, I think the first thing to try would be to simply disable the plugin and then enable it once again being logged in into that admin (or super-admin in case of WordPress Multisite) that you’re currently using the most.

    If this doesn’t help you may want to add following line to your site’s “wp-config.php” file:

    define('WPMUDEV_LIMIT_TO_USER', '1, 10');

    where numbers are IDs of admin-role accounts that you wish to be able to make use of the plugin features. After adding that line it may be necessary to disable and re-enable the plugin again.

    Best regards,

    Adam

  • Predrag Dubajic
    • Support

    Hi @Ingenieurbüro Dr. Plesnik GmbH,

    I just registered another account on your site, this time while the HTML templates are enabled and emails are still clickable on my end.

    Can you tell me which email service you are using?

    Also, if the email you received ends up in spam/junk folder make sure you move it to your inbox folder and mark it as safe as it’s possible that your email client is blocking the link in email.

    Let us know how it goes.

    Best regards,

    Predrag

  • Ingenieurbüro Dr. Plesnik GmbH
    • Site Builder, Child of Zeus

    You can follow the same process on the website “www.google-meets-business.de” and “www.badaudiobasement.com” all of them use the plug-in and kill the links of the originally generated wordpress system messages.

    The problem is 100% caused by HTML template plug-in since only switching it off resolves it. I have testet on all websites and with onlt HTML template active the problem is there.

  • Predrag Dubajic
    • Support

    Hi @Ingenieurbüro Dr. Plesnik GmbH,

    Below is the email I received when I click on reset password on your site, and Passwort erneuern link is clickable on my end.

    Can you tell me which email you are using for testing, gmail, hotmail, yahoo etc. so I can try testing in same one?

    Best regards,

    Predrag

  • Ingenieurbüro Dr. Plesnik GmbH
    • Site Builder, Child of Zeus

    Hi,

    you are a champion wihtout knowing :slight_smile: .

    Thanks for the screenshot. I know why the HTML mails act up in places. It is due to the “TML” Plug-In which I use with custom E-Mails for user registration. But with the sign up E-Mail having not text put in the standard WP text gets put in place. It seems that the “TML” Plug-In is using plain text if no custom message is provided. Thus creating the error of a non clickable link upon first sign up to recover password.

    Sometimes it is really tricky. Even with “TML” deactivated this behaviour presists. So that is why I assumed incorrelty the error would reside from your HTML Plug-in.

    Thanks for the effort and quick support!

  • Predrag Dubajic
    • Support

    Hi @Ingenieurbüro Dr. Plesnik GmbH,

    Glad to hear you managed to find the cause of this, I had a quick look at the TML plugin and can see that it offers HTML emails on it’s own so it’s possible these two are not playing well because of that.

    What happens if you leave the TML email empty but still select HTML instead of plain text?

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi @Ingenieurbüro Dr. Plesnik GmbH,

    You can submit the error using our contact form https://premium.wpmudev.org/contact/

    Make sure you select “I have a different question” for your topic and as subject enter “Attn: Predrag Dubajic” so it gets assigned to me.

    Please include this thread URL in the content.

    Can you tell me what triggers Antispam Bee emails so I can test this?

    Also, which emails service are you using, gmail, hotmail/outlook, yahoo…?

    Note: Threads can always be marked as Not Resolved by original poster and staff members so you don’t have to worry if you mark thread as resolved and need to respond later on :slight_smile:

    Best regards,

    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hello Ingenieurbüro Dr. Plesnik GmbH!

    In this case it’d be worth examining e-mails directly in Thunderbird. I’m working on Windows 10 but hopefully Thunderbird would behave in a similar way to its Mac version. Could you please forward that same e-mail that you already forwarded to my colleague Predrag to me? Use adamwpmudev [at] gmail.com please.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello @Ingenieurbüro Dr. Plesnik GmbH!

    Thank you, I received that forwarded message. Thunderbird 45.1.1 on Windows 10 shows all the links as active and I’m able to use them. I reviewed e-mail source and it looks perfectly fine. I also checked if there are any Thunderbird “default” settings that could cause links to be “converted” to plain text but found none.

    I did found however that this is not an uncommon issue and there’s even entire troubleshooting section for this on Mozilla’s help pages. That said, just to make sure that we didn’t miss anything here, could you please follow their guide? Here’s an article I’m referring to:

    https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working

    Please double-check each described step and let me know if this affected the issue.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.