HTTP 500 after user registration

I was having trouble enabling Captcha on the above website, so Adam Czajczyk help me replace my sign up page for a pop-up created by Hustle plugin. It resolve the issue and now I have the captcha in the sign up form, but after clicking "Register" I get a HTTP 500. The user is created though. Looking at the apache log, I can see the following error: "[Mon Apr 15 14:05:33.925582 2019] [php7:error] [pid 3469] [client 71.188.122.201:62848] PHP Fatal error: Uncaught ArgumentCountError: Too few arguments to function wp_custom_user_redirect(), 1 passed in /var/www/jobsulting.consultingquest.com/public_html/wp-includes/class-wp-hook.php on line 286 and exactly 2 expected in /var/www/jobsulting.consultingquest.com/public_html/wp-content/themes/jobify-extended/functions.php:251\nStack trace:\n#0 /var/www/jobsulting.consultingquest.com/public_html/wp-includes/class-wp-hook.php(286): wp_custom_user_redirect('/':wink:\n#1 /var/www/jobsulting.consultingquest.com/public_html/wp-includes/plugin.php(208): WP_Hook->apply_filters('/', Array)\n#2 /var/www/jobsulting.consultingquest.com/public_html/wp-content/plugins/woocommerce/includes/class-wc-form-handler.php(1092): apply_filters('woocommerce_reg...', '/':wink:\n#3 /var/www/jobsulting.consultingquest.com/public_html/wp-includes/class-wp-hook.php(286): WC_Form_Handler::process_registration('':wink:\n#4 /var/www/jobsulting.consultingquest.com/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)\n#5 /var/www/jobsultin in /var/www/jobsulting.consultingquest.com/public_html/wp-content/themes/jobify-extended/functions.php on line 251, referer: https://jobsulting.consultingquest.com/"
So I need help trying to figure it out.
I already tried to remove the custom code suggest by Adam and also disabled the captcha plugin, but the HTTP 500 is still there. So it's no related to that.

Thank you.

  • Nithin
    • Support Wizard

    Hi Laurent,

    Hope you are doing good today. :slight_smile:

    Could you please make sure you have the following option Anyone can register enabled under Settings > General in the WordPress dashboard?

    If not, please check that setting, and save the changes to see whether you could still replicate the issue, or not.

    If you still notice the same issue, the above logs point to WooCommerce plugin. Do you have any WooCommerce plugin add-ons? If yes, only keep WooCommerce plugin enabled, and keep other plugins related to WooCommerce disabled to see whether the issue still occurs.

    This would give a better idea of where the issue is. If none of the above resolves, then please grant support staff access so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Laurent
    • Design Lord, Child of Thor

    Hi, Thank you for your answer. I have several woocommerce plugins. I have:
    - Admin Columns Pro - WooCommerce - now deactivated.
    - Simple Registration for WooCommerce - Cannot deactivate, because this is my sign up form
    - WC4BP -> WooCommerce BuddyPress Integration premium - now deactivated
    - WooCommerce PayPal Powered by Braintree Gateway - now deactivated.
    - WooCommerce Subscriptions - now deactivated.

    Still the same issue after deactivating all plugins above. I have to reactivate the plugins in order to the rest of the site work properly. Support access is now active.

    Thank you.

  • Ash
    • WordPress Hacker

    Hello Laurent

    The issue is with your theme, the error come from /wp-content/themes/jobify-extended/functions.php line no 251 - wp_custom_user_redirect() function should have two arguments passed while calling but your theme passed only one.

    Please contact the theme author, they should be able to fix the issue. Otherwise, send us the file /wp-content/themes/jobify-extended/functions.php and we will take a look just in case if we can fix it.

    Have a nice day!

    Cheers,
    Ash

  • Laurent
    • Design Lord, Child of Thor

    Hi Ash,

    The jobify-extended is the child theme and the functions.php was completely customized by our developer, who is not available anymore. So, yes, I will need your help to fix it. Here is the link to the file: https://consultingquest.box.com/s/bjomj39bn2awff2qj912qbbwa8sfmrso

    As far as I can see, the wp_custom_user_redirect need 2 parameters: $redirect, $user. Redirect is the page to redirect the user based on its role and the user is, well, the user. When I click the Register button, only one parameter is getting there. So need the button to pass both parameters.

    Thank you.

  • Kasia Swiderska
    • Support nomad

    Hello Laurent ,

    Could we get some more access to debug this issue and see if we can fix this issue? FTP and WP admin credentials (support access can expire or stop working, so it's better to have those, just in case).

    Note: Don't leave your login details in this ticket and please confirm here that you send those credentials

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Kasia Swiderska"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    kind regards,
    Kasia

  • Ash
    • WordPress Hacker

    Hello Laurent

    Thanks for sharing the functions.php code. Please comment out the following line:

    add_filter( 'woocommerce_registration_redirect', 'wp_custom_user_redirect2',10 );

    Just make it like this:

    //add_filter( 'woocommerce_registration_redirect', 'wp_custom_user_redirect2',10 );

    This is line no 285.

    Please let us know if that works for you. Have a nice day!

    Cheers,
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.