Http error 403 randomly

Hi, EDITED

It is a multisite environment. Main site works good. no error for visitors.
But the subsite /verrijzenisgemeenschap/ gives http error 403 to a lot of visitors so much that visitors are getting blocked by iThemes security plugin.

I have just flushed permalinks (just wento to the permalinks settings and saved without making any changes).

Is there anything else I can do to guarantee it will at least decrease the errors?
access is granted :slight_smile:
Cheers

  • Predrag Dubajic

    Hey mpress,

    Hope you're doing well today :slight_smile:

    I tested your site with multiple site testing tools like gtmetrix, site24x7, geopeeker, dotcom-tools, dnschecker,... and I'm getting some inconsistent results from them.

    I'm not sure what could be causing this and best thing to do is get in touch with your hosting provider so perhaps they can give you some additional info after checking server logs.

    Best regards,
    Predrag

    • mpress

      Thanks for checking it out Predrag Dubajic .

      What weird is that it looks like this behaviour happens only with the subsite. I have checked with the admin from the main site and they say no complains about errors messages from visitors.

      I have already opened a ticket support at the webhosting provider.
      Let's see what they have to say about it.

      Is there anything else I could do in the mean time?
      I still have some hard time checking the homepage using WP-super cache. Jude was assisting me with, he gets the time stamps ok with wp-super cache, but I still do not get stamps time to be ok when testing site.

      Cheers.

  • Adam Czajczyk

    Hello mpress!

    I think at this stage it would be good to wait for host's response on that. They should be able to check server logs against these errors and either help you or at least identify some resources/troublesome assets etc and this could point us in a right direction.

    However, after checking your site I think it may be worth to:

    1. Raise the WordPress memory limit

    Currently your Multisite is going on 64M memory limit of total 256M available. I understand that the issue happens on a specific subssite only but it's very possible that this sub-site is "suffering" because of that limited memory. Raising that limit won't do any harm to main site and other sub-sites (it can only help) but may increase performance of the sub-site in question.

    To raise the limit, add following lines to the "wp-config.php" file of your WP install:

    define('WP_MEMORY_LIMIT','256M');

    This line should be located above the "/* That's all, stop editing! */" line (otherwise it may either not take effect or even break the site).

    Add it there and see if that helps. If not, leave it there please and

    2. Try switching off the "Coarse file locking" option on "Settings -> WP Super Cache -> Advanced" page of the sub-site in question. It's meant to improve performance on some servers but it shouldn't make very big difference in performance and there's a warning that in some cases it may cause issues.

    3. If that doesn't decrease number of 403 errors, see if disabling WP Super Cache entirely help, just to test it.

    Best regards,
    Adam

  • mpress

    checking out for the lockout log from ithemes, that is also (I think) related to this, I have found that this is the url from a 404 error:
    http://stjandedoper-vechtenvenen.nl/verrijzenisgemeenschap/wp-content/uploads/sites/4/wp-hummingbird-cache/122cc2ed0382dc6b312969152ccdeccf.css
    How can I be sure it is not Hummingbird that is giving some 404 errors? then getting visitors lockout?

    I have checked some others and they look like too to be related to Hummingbird.

    table itsec_log from Ithemes.

    Cheers

  • Predrag Dubajic

    Hi mpress,

    404 errors are referring to files that couldn't be found on your server, in this case css and font files, I'm quite sure that this shouldn't be causing 403 error your users experienced.

    Missing HB CSS file suggests that there's missing minified file so I would suggest going to Minification panel and there saving settings so that new minified files are created, clear your caching plugin and see if the error is still there after that.

    Have you tried disabling Minification or HB altogether, even though I don't think this could be causing you issues it's worth giving it a try?

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello mpress!

    Hummm... save changes or re-check files?

    If you did not disabled minification, there's no need to. I would however proceed this way in order to find out if it's Hummingbird and if so, what part of it:

    1. Go to "Hummingbird -> Minification" and disable it entirely
    2. Disable "Hummingbird" plugin
    3. Clear all cache

    If an error doesn't come up anymore:

    4. Enable "Hummingbird" (don't enable minification yet)
    5. Clear cache

    If an error still doesn't come up

    6. Go to the "Hummingbird -> Minifications" page
    - run "Re-check" files
    - after check is complete "Save settings"
    7. Clear site's cache again

    If that is indeed Hummingbird's fault or a matter of Hummingbird conflict with another plugin/setting, this should show that.

    Best regards,
    Adam

  • mpress

    Hi Adam Czajczyk en Predrag

    This is what I got from the hosting provider - they say they are 404 erros ( how to get rid off these errors?):

    "GET /verrijzenisgemeenschap/wp-content/uploads/sites/4/fonts/fontawesome-webfont.woff2?v=4.7.0 HTTP/1.1" 404 38367 "http://stjandedoper-vechtenvenen.nl/verrijzenisgemeenschap/one-het-schakeltje/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14" 745 38367
    
    "GET /verrijzenisgemeenschap/wp-content/uploads/sites/4/fonts/fontawesome-webfont.woff?v=4.7.0 HTTP/1.1" 404 38362 "http://stjandedoper-vechtenvenen.nl/verrijzenisgemeenschap/one-het-schakeltje/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14" 744 38362
    
    "GET /verrijzenisgemeenschap/wp-content/uploads/sites/4/fonts/fontawesome-webfont.woff?v=4.7.0 HTTP/1.1" 404 38374 "http://stjandedoper-vechtenvenen.nl/verrijzenisgemeenschap/one-het-schakeltje/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14" 744 38374
    
    "GET /verrijzenisgemeenschap/wp-content/uploads/sites/4/fonts/fontawesome-webfont.woff2?v=4.7.0 HTTP/1.1" 404 38381 "http://stjandedoper-vechtenvenen.nl/verrijzenisgemeenschap/contact/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14" 734 38381
    
    "GET /verrijzenisgemeenschap/wp-content/uploads/sites/4/fonts/fontawesome-webfont.woff?v=4.7.0 HTTP/1.1" 404 38367 "http://stjandedoper-vechtenvenen.nl/verrijzenisgemeenschap/contact/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_1) AppleWebKit/602.2.14 (KHTML, like Gecko) Version/10.0.1 Safari/602.2.14" 733 38367
  • Predrag Dubajic

    Hi mpress,

    do you mean deactivate Hummingbird in entire network?

    HB can only be network activated so you should network de-activate it as well.

    Are the errors from your last post shown after disabling HB?

    Did you check the folder mentioned in the error via FTP to see if those files are missing?
    When you go to /wp-content/uploads/sites/4/fonts/ folder do you see fontawesome-webfont.woff file in there?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.