http instead of https shown in sitemap URL


As we have an SSL certificate, our domain URL is prefixed “https:” however the sitemap URL in SmartCrawl settings is showing as prefixed with just “http:”. It still loads to Google & Bing ok, so no functionality issue, just a niggle I suppose that it’s not quite right?

NB. Domain with “https:” is correctly set in our “wp-config” file.

Look forward to hearing your comments.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @prize_days___paul,

    Hope you are doing good today :slight_smile:

    Thanks for reporting this issue. I don’t have SSL configured so can not test on hand. Could you grant support staff access so I can take a closer look.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access or see this manual for more details.

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

  • Nastia
    • Support Rock Star

    Hello @bize, I hope you are doing well today!

    Thank you for granting access to your site. I’ve looked at your sitemap and all the links have https protocol. I guess it needed some time to update the URLs.

    Let us know if you require any further assistance!



  • BizE
    • Site Builder, Child of Zeus

    Hi Nastia

    I think there is a misunderstanding with the issue here. We know the sitemap is displaying ok, but what is confusing us is why the SmartCrawl settings page still show our sitemap URL as just http – I have attached a screenshot for you.



  • Nastia
    • Support Rock Star

    Hello Paul!

    I hope you are doing well today!

    I see what you mean, you don’t need to be concerned about this. As I believe inside the plugin, while creating sitemap it checks either it is http or https and sitemap with https is working perfectly in your site.

    Is the SSL certificate is enabled on all of your sites in the database? If not, then in settings you will not see https protocol.

    Please advise,

    Kind Regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.