HTTPS Admin Issues

I’m wondering what I’m missing here…I log into the admin area over SSL/HTTPS. But when I try to do just about anything (especially with the Admin bar), the links are just HTTP. So I end up getting the non-SSL login screen just about any time I try to navigate anywhere.

Is there a way to make things work as expected when you’re logged in via SSL?

Thanks,

Mark

  • DavidM
    • DEV MAN’s Mascot

    Hi Mark,

    I’ve not attempted SSL in WordPress as yet, so I’ll ask a few of the guys over here who may be more familiar with it to chip in.

    I’m wondering though, would it be all the links in the Admin Bar that are acting that way? Also, are there particular links that do work?

    Cheers,

    David

  • wpcdn
    • Syntax Hero

    Hi,

    There’s a define for wp-config:

    define(‘FORCE_SSL_ADMIN’, true);

    Do you have that enabled?

    No, because I’m not trying to force SSL for everyone (due to performance issues). However I want it to work properly when users choose to use it.

    Example: I’m logged in securely and I click the link to visit the site. The site then has the admin bar, but when I click the “Dashboard” link to return to the Dashboard, I’m taken to the non-secure version of the login page. In that case I just want to return to the Dashboard I’m already logged into securely.

    There are various similar examples. :slight_frown:

    Mark

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.