https issues with upfront media paths

bug report: Looking through my console and noticing a bunch of https mixed issues when editing in https mode with upfront, here's my console:

(index):1 Mixed Content: The page at 'https://topnetworkname.com/subblogname/' was loaded over HTTPS, but requested an insecure font 'http://topnetworkname.com/subblogname/wp-content/themes/uf-spirit/fonts/Meg.woff'. This request has been blocked; the content must be served over HTTPS.
(index):1 Mixed Content: The page at 'https://topnetworkname.com/subblogname/' was loaded over HTTPS, but requested an insecure font 'http://topnetworkname.com/subblogname/wp-content/themes/uf-spirit/fonts/Meg.ttf'. This request has been blocked; the content must be served over HTTPS.
(index):1 Mixed Content: The page at 'https://topnetworkname.com/subblogname/' was loaded over HTTPS, but requested an insecure image 'http://topnetworkname.com/subblogname/wp-content/themes/uf-spirit/images/sprite.svg'. This content should also be served over HTTPS.
Mixed Content: The page at 'https://topnetworkname.com/subblogname/' was loaded over HTTPS, but requested an insecure font 'http://topnetworkname.com/subblogname/wp-content/themes/uf-spirit/fonts/Meg.woff'. This request has been blocked; the content must be served over HTTPS.

I'm using the latest wordpress 4.2.2 and nginx with upfront spirit theme

  • Michael Bissett

    Hey @Ben, hope you're doing well this evening! :slight_smile:

    Inside of the Upfront editor, if you go to:

    Theme Settings -> add custom css rules

    You'll want to scroll down in the CSS editor until you see this section of code:

    @font-face {
        font-family: "Meg";
        src:url("http://dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.eot");
    	src:url("http://dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.eot") format("embedded-opentype"),
    		url("http://dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.woff") format("woff"),
    		url("http://dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.ttf") format("truetype"),
    		url("http://dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.svg") format("svg");
    	font-weight: normal;
    	font-style: normal;
    }

    Try changing that to this please:

    @font-face {
        font-family: "Meg";
        src:url("//dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.eot");
    	src:url("//dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.eot") format("embedded-opentype"),
    		url("//dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.woff") format("woff"),
    		url("//dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.ttf") format("truetype"),
    		url("//dev4.codeweasel.net/wp-content/themes/uf-spirit/fonts/Meg.svg") format("svg");
    	font-weight: normal;
    	font-style: normal;
    }

    And letting me know if that helps. :slight_smile:

    Thanks in advance!

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.