https issues with whmcs plugin

I'm experiencing issues with this plugin since i try to use HTTPS in both wordpress and WHMCS.

For example the order process works ok as you can see at:
http://www.amitosai.com/mi-cuenta/clientes/cart.php/?a=add&pid=82&currency=2

But if you try to use the domain checker you will get a blank page:

https://www.amitosai.com/mi-cuenta/clientes/domainchecker.php?currency=1

And if you try to get the customer page, you get a corrupted page:
https://www.amitosai.com/mi-cuenta/

All the links works ok until I activate SSL, bur i really need it activated.

I have the following error in the php logs on server:

[28-Aug-2014 15:53:45 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/amitosai/public_html/wp-content/plugins/wordpress-https/wordpress-https.php:1) in /home/amitosai/public_html/wp-content/plugins/whmcs-wordpress-integration/whmcs-integration.php on line 350
[28-Aug-2014 15:53:45 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/amitosai/public_html/wp-content/plugins/wordpress-https/wordpress-https.php:1) in /home/amitosai/public_html/wp-content/plugins/whmcs-wordpress-integration/whmcs-integration.php on line 350
[28-Aug-2014 15:54:03 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/amitosai/public_html/wp-content/plugins/wordpress-https/wordpress-https.php:1) in /home/amitosai/public_html/wp-content/plugins/whmcs-wordpress-integration/whmcs-integration.php on line 350
[28-Aug-2014 15:54:17 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/amitosai/public_html/wp-content/plugins/wordpress-https/wordpress-https.php:1) in /home/amitosai/public_html/wp-content/plugins/whmcs-wordpress-integration/whmcs-integration.php on line 350
[28-Aug-2014 15:54:27 UTC] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/amitosai/public_html/wp-content/plugins/wordpress-https/wordpress-https.php:1) in /home/amitosai/public_html/wp-content/plugins/whmcs-wordpress-integration/whmcs-integration.php on line 350

  • Patrick

    Hi there @dacstyle

    I hope you're having a great day!

    The first thing to check is that you have correctly entered the information in both your WordPress site and your WHMCS install.

    Please double-check that the URLs you have entered at both sites are identical. In other words, if one is HTTPS, they must all be HTTPS. If one is WWW, they must all be WWW.

    Also, please ensure that the domain you enter in the "Remote WHMCS Host" setting in your WordPress ends with a slash " / "

    Finally, at your WHMCS install, please be sure that you have entered your HTTPS address in the "WHMCS System URL" field, not the "WHMCS SSL System URL" field.

    See "Configuring the Settings" on the usage page for more details & screenshots:
    https://premium.wpmudev.org/project/whmcs-wordpress-integration/#usage

    Please do let us know if this helps, and don't hesitate to post again if you need more info on this.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.