https not loading on subsites with WP update

Hello,

About a year ago, we had an issue with subsites creating an infinite loop when trying to access https..

The solution last year was to do the following:

_____________ excerpt of conversation ________________

Yeah the certs are setup correctly :slight_smile:

I found the issue but I am not sure what caused it. My techs commented out the following in the core (I know)...

comment out lines 6&7 in template-loader.php in includes

//if ( defined('WP_USE_THEMES') && WP_USE_THEMES )
//do_action('template_redirect');

I am not sure what caused this. We create child themes off Canvas. Another forum said it was a plugin. I am not so convinced. The main site in multiuser worked fine. It was only the subsites and this applied to all subsites with different plugin configs. I have a few network enabled.

___________________

We never found out what was causing the https error on subsites only other than commenting this out. Now when the same lines are commented out, it doesn't resolve the issue.

At the time, I thought it was because we had //define('WP_DEFAULT_THEME', 'Canvas'); in the wp-config but removing it didn't fix the issue.

Anyway, I have some others looking at it and you guys always have great ideas, so you help is greatly appreciated.

  • maxwebgear
    • The Incredible Code Injector

    I just posted a question to the general wordpress forum and then we figured it out internally so I posted the "solution".

    I have my previous version and I could revert it but it would be nice to figure it out so I don't have to cross this road again the future.

    Is there a solid methodology for narrowing this down besides disabling plugins, etc until the problem resolves?

    I am not sure its not an issue with wp-config or htaccess. it would be great to have a way to eliminate these files quickly.

    Thanks again and happy holidays.

  • maxwebgear
    • The Incredible Code Injector

    FYI. I found the problem after removing all htaccess, plugins, themes, etc. It was the new version of domain mapping. Version Version: 4.2.0.6 is redirecting all https back to http. I reinstalled version Version: 4.1.4.2 and all is now working.

    We are using subdomain configuration with wildcard SSL's. I am moving this to a new ticket addressing it directly with the domain mapping plugin. Thanks for your help.

    • wp.network
      • The Bug Hunter

      @maxwebgear you are not alone :slight_smile:

      Seems like there are many threads on buggy behavior in current Domain Mapping... presumably Sam is hard at work, yet I can't really say anything other than that I have seen a bunch of somewhat similar threads lately that are just kinda 'paused' with no resolution and little clear communication.

      Personally, I've started thinking that WPMUdev Domain Mapping as a project, is understaffed. There is a limit to what a single person can do.

      I'd like to know if Domain Mapping has a dedicated dev team (like MarketPress now does)? If not, why not?

      For now, it is the way it is, and so it goes... Good Luck :slight_smile:

      Kind Regards, Max

      • maxwebgear
        • The Incredible Code Injector

        I agree. This is one of the foundational elements of a successful multi-site campaign. I can say definitely the previous version of domain mapping works seamlessly and I am having to troubleshoot this version. Its pretty frustrating to set-up tests when I have eliminated all other plugins and the theme.

        I need to trust WPMU's updates a little more than what I am getting with this plugin.

  • Tyler Postle
    • CGO

    Hey there Max,

    Hope you're doing well today!

    It sounds like you have a plugin or .htaccess code that is already controlling your subsite https/http forcing then domain mapping is conflicting with that because it has https/http forcing options of it's own.

    In your network admin > Settings > Domain Mapping. Scroll down to "Would you like to force http/https in frontend pages and select "No". this will get rid of any https or http forcing from domain mapping so you can use your own methods :slight_smile:

    Another solution would be to get rid of your other method and then just use domain mappings forcing options.

    If this isn't the case then it sounds like it could be theme related still, does it work fine on subsites when you switch to just the default 2015 theme?

    If it does and it does look to be conflicting with the theme, then do you mind sending in your FTP credentials so we can grab a copy of your theme off you and test it out? :slight_smile: or you can just send the theme in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    **If you want to just send the theme in then using your normal email client(our contact form doesn't have an attach option) send it to contact [at] wpmudev.org.

    Look forward to hearing back on this maxwebgear!

    Cheers,
    Tyler

  • maxwebgear
    • The Incredible Code Injector

    Thanks for the reply. I will check this out. I know I eliminated all the plugins and theme from the equation. I was basically running multiuser with domain mapping. When I reverted to the previous version of the plugin, all worked. I will get this scheduled for tomorrow.

  • maxwebgear
    • The Incredible Code Injector

    Okay, all the settings were as you set them. It's still not working. I tried with a standard theme with no luck. The theme in question in Canvas. It's up to date. I can send it or you can grab it from their site.

    Please advise as this is keeping us from updating this plugin.

    Thanks

  • Michael Bissett
    • Recruit

    Hey @maxwebgear.

    Have you tried the version of Domain Mapping that @WPMS.Network referenced here? Did it work for you? :slight_smile:

    If not, could you then please send in the following:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks! :slight_smile:

    Kind Regards,
    Michael

  • maxwebgear
    • The Incredible Code Injector

    Michael,

    The contact form looks like it could be public and I don't want to take a chance publishing this information. Sorry for the delay, but it takes a little time to set all this up for you. The problem definitely still exists.

    Rackspace is seeing a lot of errors like below and it looks like its impacting other components of the site.

    [Mon Mar 09 18:46:17 2015] [warn] [client 99.21.54.243] mod_fcgid: stderr: WordPress database error Table 'MWG_domain_mapping' already exists for query RENAME TABLE MWG_domain_map TO MWG_domain_mapping made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), include_once('/plugins/domain-mapping/domain-mapping.php'), domainmap_launch, Domainmap_Plugin->set_module, Domainmap_Module_System->__construct, Domainmap_Module_System->_upgrade, apply_filters('domainmaping_database_upgrade'), call_user_func_array, Domainmap_Module_System->setup_database, referer: http://domain.com/path/

  • Vaughan
    • Support/SLS MockingJay

    Hi Max,

    As long as you select 'I have a different question' then it will be sent securely via email to our email system.

    Alternatively, if you don't wish to use the contact form, you can send via email directly to contact[at]wpmudev.org

    Hope this helps

  • Michael Bissett
    • Recruit

    Hey @maxwebgear,

    I noticed that the staff access you had enabled (mentioned in the email you sent) has expired, could you either re-enable it please, or send in the network admin login details (as requested earlier)? I tried using the details that were sent in the email, but those didn't look to be network admin details.

    I should note though that there's been a few versions of Domain Mapping released since my post on 11th of last month, which may resolve this issue for you. If you'd like to try updating here, and seeing if that works, you're more than welcome to. :slight_smile:

    Kind Regards,
    Michael

  • maxwebgear
    • The Incredible Code Injector

    Yeah. I updated, deleted all other plugins, went with a default theme and the SSL loops. When I use the older plugin... all works well.

    WPMU assigned this to the developer I think. He has all access. Hopefully they will resolve it soon.

    Thanks again,

    Ken

  • Sam
    • The Incredible Code Injector

    hi @maxwebgear

    The credentials you've provided in the email don't work for the network admin and the support access doesn't work either, could you please update these before i can take a look?

    Thanks,
    Sam

  • maxwebgear
    • The Incredible Code Injector

    Sam,

    I just checked the login info and it worked according to my notes. I also extended the support portal. March 22, 2015 12:14 am. Can you please send me personal email so I can validate what I sent you to make sure I didn't make a typo, etc.?

  • Sam
    • The Incredible Code Injector

    Hi @maxwebgear

    I'm gonna update the plugin and take a look, i've backed up the plugin but need to make sure you have db backup as well, if you don't please backup ur db or send cpanel creds so that i can backup and move forward.

    Thanks,
    Sam

  • Sam
    • The Incredible Code Injector

    Hi @maxwebgear

    Is it update at 5pm EST or backed-up at that time? i need to make sure you have a backup before i proceed with updating the DM plugin and take a look.

    Please let me know about your back-up plan/routine so that i can update DM and take a look asap.

    Thanks,
    Sam

  • Michael Bissett
    • Recruit

    Hey @maxwebgear! :slight_smile:

    We didn't receive any further word from you on the backup process here on the thread, as @Sam had asked regarding this:

    I is updated daily at 5pm EST.

    He wanted to make sure that your site was backed up at that time of day, or if not, what the backup schedule was here.

    Given the situation though, could you please send in the cPanel credentials, so that he can make his own backup, and thus be able to proceed further in diagnosing your site? I've requested them via email, please respond over there. :slight_smile:

    Thanks a bunch for your patience in the meantime! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett
    • Recruit

    Hey @maxwebgear, my apologies for the delay here! :slight_frown:

    I'm seeing that there's WordPress network admin details & FTP details sent in, but I'm not seeing that you sent in any Plesk details?

    If you could reply to the email that I sent on the 6th asking for those details, and get those sent in, we'd be glad to proceed further with this.

    My apologies once again for the delay, I'm keeping a special eye on this thread, so that I don't miss your reply here!

    Kind Regards,
    Michael

  • maxwebgear
    • The Incredible Code Injector

    Hello. Is there a way to create a clear communication channel? I've had this issue for about 2 months now and it seems I provide one thing, but by the time you guys can get to it (I understand) the admin access expires, then I turn it on and something else is needed. Not complaining just want to get this resolved so I can update things.

    Please send me a private email with your planned date to work on it, so I can have everything up. I will also send FTP to that address as well once I get a support date.

    (I have been busy too, so I can't point the finger too hard). :slight_smile:

  • Michael Bissett
    • Recruit

    Hey @maxwebgear,

    As noted in my last response, we were last waiting on receiving Plesk details from you, hadn't seen those sent in yet?

    Having a "support date" wouldn't be feasible, as we'd rather get this done for you ASAP. But we would need the necessary credentials to actually have a look at that (as the lack of those has been why there hasn't been any further activity on this for the past 3 weeks). :slight_smile:

    So that we can get this wrapped up once and for all, and so that the all of the access details are all in one place, could you please send in the following to me:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password) - make sure that the user is indeed a network and, don't enable Support Access for this
    - Include FTP log-in details (hostname, username & password)
    - Include Plesk log-in details (login address, username & password)
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Once you've sent those in, I'll let the developer know that you've sent them in, so that he can have a look at your site. :slight_smile:

    Thanks a bunch!

    Kind Regards,
    Michael

  • maxwebgear
    • The Incredible Code Injector

    I just resent everything. Please let me know if you got it. Sorry for the delays on my part. It's hard to work in a time to check logins, reset pw and resend info.

    Please confirm this was received.

    I appreciate your help.

    Thanks,

    Ken

  • Sam
    • The Incredible Code Injector

    Hi @maxwebgear

    I've updated you the RC version of DM and things seem to be fine.
    If you encounter any issues please let me know how to reproduce them on step by step on your site so that i can help more.

    Cheers,
    Sam

  • maxwebgear
    • The Incredible Code Injector

    Works like a charm. The dreaded loop is gone once down graded. I did notice someone updated Wordpress version. We didn't perform any upgrades because we were waiting on a fix. If you refer to the website in the notes. You can just add a product and check out to see the error when updating. The primary domain has no issues. Just subsides mapped. It's getting stuck in a loop when going to https. Not sure what's different in the plugin versions... Your help is greatly appreciated.

  • Sam
    • The Incredible Code Injector

    Hi @maxwebgear

    Alright the issue is spotted, since 4.3.0 DM starts forcing scheme ( http/https/none ) for mapped domains, when u'r adding a mapped domain u could select "Force none" from the dropdown but since you were upgrading, your default schemes where "http' ( meaning force http ) which would end up in a redirect loop when you're forcing https for your checkout pages using some other methods rather than DM.

    I've set all your mapped domains default scheme to "Force none" for now but later on when you remove the other method of forcing https, you can use DM to do this for your, either for the entire mapped domain or using the force ssl table to force single pages by id or by url.

    What i'm going to do is try to allow the toggle button ( the key icon ) in settings page to toggle to "force none" so it's more clear.

    Thanks for your patience.
    Cheers,
    Sam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.