https not used for Twitter profile photo

I just tried your Comments + plugin and it went pretty well, but Firefox started to show an exclamation mark against my padlock, so I checked the page and found that the profile photo that is embedded from Twitter is not using https.

http://pbs.twimg.com/profile_images/470000847791747072/Y5GO6ILG_normal.jpeg

The image still loads if you add the s to http, so it would be great if you could ensure that these images are displayed using https when the site (my wordpress installation) is using https.

I've got to disable the plugin for now, to get my clean padlock back, but I hope you can modify the code to include this at some point.

  • Martin
    • Design Lord, Child of Thor

    Hi Jude,

    Thanks for looking into this. I've reactivated the plugin and granted support access. This is a production site, so please do not deactivate any plugins or make any changes other than the Comments + plugin settings.

    I have only just installed the plugin, so I assume it's the latest version.

    I also just noticed that when I click on Google on the front end, I no longer get an option to login and there's no comment field either. I can take a look later, but if you notice a reason for that, could you let me know about that too please?

  • Martin
    • Design Lord, Child of Thor

    Hi again Jude,

    Just a quick update. I cleared my browser cache and the problem with the Google tab cleared up. I'll keep my eye on this, but I think it's OK now. So, it's just the none http issue that I'm currently concerned about.

    Thanks again for your help!

  • Martin
    • Design Lord, Child of Thor

    Thanks Jude.

    It's fine to install that plugin, but you'll have to hit the button to clear the cache afterwards. The same goes for after making any changes that effect the front end.

    Go to Settings > WP Rocket > Tools and hit the Clear Cache button. Also, after the browser has refreshed, hit the Purge Opcache button as well.

    Please note though that I don't want to run a plugin like that as a fix. My site runs 100% over SSL normally, so I need that to continue without a plugin to force it. I'm sure that's not your plan, but I thought I'd mention this.

    Thanks again for your help!

  • Ivan Shulev
    • The Bug Hunter

    Hey Martin ,

    I hope you are having a nice day and I am sincerely sorry for the delay here!

    I am afraid the support access has expired and I will have to ask you to enable it again.

    I see we have some login credentials via email, but you have 2 registered websites and I am not certain for which one this issue applies, as I do not see Comments + installed on either of them.

    Again, I am sorry for the inconvenience we have caused and I thank you for your patience!

    Ivan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.