HTTPS not working for VIDEOS

my domain name is https://themebuilding.studio
I set up a test page
https://themebuilding.studio/blog/2016/10/14/test/
Videos will only play on HTTP and NOT HTTPS how do I fix this ASAP
Ive granted you access in my dasboard

  • Sajid
    • DEV MAN’s Sidekick

    Hi robertvideo,

    Hope you are doing good today!

    Yes, I can see this issue on your website but I could not replicate this on my own site using HTTPS. The plugin detects if the WordPress site is on SSL and changes the URL to videos to https automatically.

    It means, that you have configured your WordPress site incorrectly.

    To fix this issue, first of all make sure your site URL is actually set to HTTPS instead of just a redirect in .htaccess.

    If that's the is the case then you have to change the URL of your website to from HTTP to HTTPS. In WordPress MultiSites you can not change URLs from dashboard unlike WordPress single sites. So you have to make this change in your database by following this article:
    https://wpengine.com/support/how-to-change-a-multi-site-primary-domain/

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • robertvideo
    • The Incredible Code Injector

    I checked the database its 100% all correct as per your link
    I set up WP for a living its set up the right way - why wont your videos SHOW on my https website and why do I see your website URL if I view videos in full screen - aka NON BRANDING videos

  • Nastia
    • Support Rock Star

    Hello robertvideo , I hope you are doing well today!

    In regards to the branding issue why dont you take a look yourself
    https://themebuilding.studio/test/ click a video in full screen and see for yourself
    you will see this screen shot - your company INFO

    I can't replicate the same with Chrome and Safari, but I can see it with the Firefox browser. I've reported this to our developer so they can have a closer look. Once there is an update, I will post it right back here, in this thread.

    I still cant view videos inside my WP dashboard

    You should find all videos in Dashboard > Video Tutorials menu. Please see the screenshot:

    Please note, that in your settings you have selected to hide all videos, this is why you can't see them.

    Please uncheck the categories you wish to be visible and save changes. After this navigate to your subsite's Dashboard > Video Tutorials to make sure that the videos are showing.

    Let us know how it went!

    Kind regards,
    Nastia

  • Aaron
    • CTO

    Unfortunately it is technically impossible to remove that message, it is a security feature in FF to prevent Phishing. You will see that on all html5 video when you make it fullscreen. For example visit youtube and click a fullscreen button there, it will say "youtube.com is now fullscreen". Other browsers do similar, but don't show the domain where the video is hosted.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.