HTTPS:// on main site of a multisite wordpress install issues

I have a multisite where users can create sites on a sub domain structure. I have pro sites installed and I am in the process of setting up stripe to take the monthly payments.
Under the stripe payment gateway settings on pro sites there is a message "When in live mode Stripe recommends you have an SSL certificate setup for your main blog/site where the checkout form will be displayed." so i set up an SSL for my site, but here is my confusion/issues.

- I did not set up a wildcard SSL because I only need the SSL on my main blog, but when i have https:// before my domain and I go to my sub domain sites I get blocked and a notification that the site is not secure.
- The main site does not show https:// unless I type that in. I followed this tutorial to try and fix this ( http://www.wpbeginner.com/wp-tutorials/how-to-add-ssl-and-https-in-wordpress/ ) and it worked when I am in the /wp-admin dashbord but still will not show a https connection on the frontend unless I specify in the URL.

So the boiled down version of my question is, how do I get an https:// connection on my main site without interfering with any of my subdomain sites that do not have an SSL so that I can take payments through prosites on my main blog and leave sub sites http://?

Thank you in advance!
Mike

  • Kasia Swiderska

    Hello Mike,

    Can you check if you changed URLs for main site to https only? In Multisite when you want to switch whole network to https you change in wp_option table siteurl and homeurl and in wp_sitemeta table siteurl meta_key - but if you want only to have main site with ssl then you should only change siteurl and homeurl in wp_option.
    Changing urls should only enable https on main site.

    Have you also added that code from article to htaccess file?

    If you are sure that you did that would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Michael

    Thank you for your reply!
    I have added the code to the htaccess file from the tutorial, however I haven't done anything with wp_option.

    I clicked the "Grant Support Access" button on my WPMU Dashboard and a loading wheel spins on the button and then nothing happens... it is not displaying a Revoke or Extend access button like the article you linked shows.

    The URL after clicking the button is showing - admin.php?page=wpmudev-support&failed=1487697254

    Is there a way to privately send you a user/pass to get into the site?

    Mike

  • Denitsa

    Hello there Michael,
    I trust you're well!

    Can you try adding the following to your .htaccess file, replacing what you previously added following the tutorial?

    RewriteEngine on
    RewriteCond %{HTTP_HOST} officetalk.io [NC]
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://officetalk.io/$1 [R=301,L]

    Also, did you install the WordPress HTTPS (SSL) plugin (https://wordpress.org/plugins/wordpress-https/) as advised in the tutorial? Please note that this plugin hasn’t been updated for a while, but it works fine and is safe to use. Here's a detailed article on using that, if the turtorial isn't working for you https://webdevstudios.com/2015/02/11/how-to-set-up-https-on-wordpress/.

    Keep us posted on the results!

    Warm regards,
    Denitsa

  • Michael

    Hey Denitsa, thank you for the reply

    I have replaced the code in the .htaccess file and installed Wordpress HTTPS (SSL) and it is still not working. The main site will still load with http: unless specifically https: is typed in.

    Every tutorial I see says to change the "site URL" and "Home" sections under the site settings, however for the main site (The only one I care to have https: on) the urls are grayed out and un editable. Another tutorial said to edit the wp_options file.... but I don't have one on my install!

    I am so lost here, seems like something many sites have gotten past but no tutorial has a solution that works.

    Any ideas on what I could be doing wrong?

    EDIT: I have even added
    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');
    to wp-config with the correct URL and https:// as another tutorial suggested and still nothing. if I type in my sites url it will load without https.

    Thank you,
    Mike

  • Michael

    UPDATE: It seems to be working correctly now... Here is what I believe my issue was.

    I had to remove define('FORCE_SSL_ADMIN', true); from wp-config.php as it was causing the front end of the subdomains to also load https:// and that resulted in a privacy error blocking the page.

    The Wordpress HTTPS (SSL) plugin was working however the I was editing the main sites home page (Fixer Theme) with Upfront. The home page was set to latest news instead of a static home page, that made it so I could not force https on the home page with the Wordpress HTTPS (SSL) plugin because there was no real page the plugin could find that was associated with it.

    So the solution that seems to have worked for now was to create a static home page and force the SSL on that specific page using Wordpress HTTPS (SSL) plugin... hope this helps anyone who is having the same issue but I feel like I might be the only one that takes this long to work through it! :slight_smile:

    Thank you,
    Mike

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.