HTTPS + Snapshot problem

I’ve noticed a problem and narrowed it down to 2 plugins: WordPress HTTPS (which allows you to run the site under SSL) and Snapshot.

If I have WordPress HTTPS active and I activate the Snapshot plugin then something goes wrong with permissions and I get a “You do not have sufficient permissions to view this page” message on every admin page.

Deactivating the Snapshots plugin or the HTTPS plugin fixes this issue. It seems to be a conflict with these 2 plugins.

Please help!

  • Paul
    • The Green Incsub

    @shaun_robinson, not familiar with the force SSL admin plugin you mentioned. I can say that Snapsho does not use any hard-coded paths. All are relative.

    But will check out the plugins under SSL to see if I have the same issues.

    Also, wondering what the point of the force SSL admin plugin is. How is this different than setting the admin url to https:// instead of the default http://

  • Paul
    • The Green Incsub

    I'm sorry to say my testing via a local development system running a pseudo SSL cert configuration I'm not able to reproduce the issue. I've tried your configuration as well as setting the post on the HTTPS page to 443 as well as settings the Settings > General admin URL to https:// in all cases I'm able to activate/deactivate Snapshot as well as navigate without issues.

    One note when I save the HTTPS settings initially I was forced to login again by WP. This I suspect is normal.

    Running WordPress 3.4.2 single site. Default TwentyEleven Theme and only HTTPS and Snapshot plugins were active.

    Here are two screenshots showing my HTTPS settings page as well as my Settings > General page.

  • Shaun
    • The Incredible Code Injector

    That’s really strange as I’ve encountered this problem with 2 sites, and I have the snapshot backup on 5 sites. The only thing in common with the 2 with the problem on are HTTPS and Snapshot, and disabling one or the other stops the problem. I’m convinced it is a conflict somehow.

    The only thing that might be different to your dev environment is that I’m actually using CloudFlare with Flexible SSL on, not a normal SSL certificate.

    Is there any way you can test this out? Would it help if I set up a test site and gave you access to it?

  • Paul
    • The Green Incsub

    @shaun_robinson, Yes, test site provided by users are much appreciated. Less trying to figure out how to build a comparable environment under my development system.

    But before we get there can you provide a screenshot of the exact error. This is the noamal “You don’t have permission to access this page” message from WordPress, correct?

    You can send access info to me direct paul [at] incsub.com

  • Shaun
    • The Incredible Code Injector

    I’m at a loss here now because I created a duplicate of the site on a subdomain and set everything up the same and it works?

    The live sites, which I can’t experiment on because they are live, are having the issue but the duplicate sites aren’t. So frustrating!

    I’ll try talking to the HTTPS plugin developer some more, I really don’t know what the problem is all I know is that it only happened when I added the Snapshots plugin.

    BTW an additional note, your ad for Appointments+ on my dashboard, as well as very annoying (I did NOT know I was going to have to put up with ads when I signed up for this plugin), breaks HTTPS by being insecure even when hidden, and in certain browsers the whole dashboard won’t load because of this:

    “The page at […] displayed insecure content from https://premium.wpmudev.org/wp-content/uploads/2012/09/appointments+.jpg.”

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.