Https - The site includes HTTP resources.

Hi there.

I changed a site quite a while ago to https - but noticed some errors in the browser link. (Where it suppose to be "green".) - get shown a (i) icon.

http://www.trainyoucan.co.za

Only info I see is:
"Mixed Content" - The site includes HTTP resources.

Also added this code to the file .htaccess with no changes:

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.trainyoucan.co.za/$1 [R,L]

Should I be concerned?

EZ

  • Dimitris

    Hey there Ez,

    hope you're doing good and don't mind chiming in! :slight_smile:

    Cleared the caching already, no difference.

    Have you tried clearing out all related caches? Like from plugins, any server side cache, 3rd party services like Cloudflare etc. Which service are you using for CDN delivery? Please advise!
    Could you also please grant us with support access to your website so we can have further inspect your setup? You can do so via WPMUDEV Dashboard plugin as detailed described here https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Only reason I use HTTPS is to improve google ranks.
    Do you think this should be any concern to me?

    That was a good thinking and a good move. You just have to remove these mixed-content errors and you should be good. :wink:

    Should the extra code not re-direct all HTTP to HTTPS?

    The code in .htaccess file can handle requests from your own domain, as long as you use a CDN for your images though, these image requests are being served via the CDN domain/path.
    That's why my colleague Predrag mentioned that this may be a case of CDN cache, as CDN should have kept a cached object before you enabled the SSL certificate.

    Warm regards,
    Dimitris

  • Adam Czajczyk

    Hello Ez,

    Thank you for granting access!

    I checked your site and it seems that these images are are explicitly called out using "http://" prefix. To fix this, please go to the "Appearance -> Theme Options" page and look into the "Footer Content" text box.

    You'll find a code like this one there:

    <td width="25%"><a href="http://learnershiptracking.co.za/" target="_blank"><img class="aligncenter wp-image-53255" src="http://www.0825507946.co.za/wp-content/uploads/2015/07/Untitled-320x2002.jpg" alt="" width="155" height="128" /></a></td>

    The URL for image source (src="http://.....) starts with "http://" prefix so you will want to change it to "https://" or you may also try to use "protocol-relative" (not depending on prefix) option by skipping the prefix at all and just starting these URLs with "//".

    A "https" example of that code:

    <td width="25%"><a href="http://learnershiptracking.co.za/" target="_blank"><img class="aligncenter wp-image-53255" src="https://www.0825507946.co.za/wp-content/uploads/2015/07/Untitled-320x2002.jpg" alt="" width="155" height="128" /></a></td>

    A "generic" example of the same code:

    <td width="25%"><a href="http://learnershiptracking.co.za/" target="_blank"><img class="aligncenter wp-image-53255" src="//www.0825507946.co.za/wp-content/uploads/2015/07/Untitled-320x2002.jpg" alt="" width="155" height="128" /></a></td>

    I hope that helps!

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.