Https to Http login bug found when using "Your Account" feature

Here is the issue:

Only happens when forced SSL is selected for a Payment Gateway.

If you login from main website like https://www.reachfirst.net/wp-admin than Your Account front end page works fine.

If you login from http://subdomain.reachfirst.net/wp-admin than Your Account page does not work.

I suspect the problem is with forced https. Because the packages page has the forced SSL so there is an issue when a user logs in from their website login page (non-SSL) rather than the main login page (SSL). For some reason, the login session is not carried over from non-SSL pages to SSL pages.

Is this a known issue? Thanks

  • Tyler Postle

    Hey Raja,

    Hope you're doing well today!

    This is actually working correctly on my sandbox. I login on http and remain login over to https. Can you try this with all your other plugins deactivated? Make sure it's not a plugin conflict. **Make sure after you turn off all plugins, and before you test, you clear your browser cookies, cache, etc.

    If it's still not working then could you grant support access so we can have a closer look?

    You can grant support access via WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back.

    Cheers,
    Tyler