Hub Not working at all

Since we moved to our new servers we have had two issues.
One - An annoying popup when we sign on through the website that says curl is not working when it is, so I have to try to login three or four times and even when I get it to log in it doesn't always stay that way.
Two - The most annoying one is that the HUB no longer works at all, see attached Image.

  • Nithin
    • Support Wizard

    Hi Jaxom,

    Hope you are doing good today. :slight_smile:

    One - An annoying popup when we sign on through the website that says curl is not working when it is, so I have to try to login three or four times and even when I get it to log in it doesn't always stay that way.

    Could you please specify what's the exact error the plugin shows? Does it say only cURL is not working?

    Are you able to download WordPress plugin from the WordPress plugin repository? It sounds like the cURL library installed in your server is outdated, could you please check this with your host, and check whether updating to the latest version of cURL library helps?

    If your host doesn't help much here, you might find the following plugin helpful:
    https://github.com/pronamic/wp-http-curl-transport-last/

    If that's not the case, please enable support access, so that I could have a better idea about this issue. Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Jaxom
    • Dragon Rider

    The pop up says:
    Your server had a problem connecting to WPMU DEV: "cURL error 6: Could not resolve host: premium.wpmudev.org; Name or service not known". Please try again.
    If this problem continues, please contact your host with this error message and ask:
    "Is php on my server properly configured to be able to contact https://premium.wpmudev.org/api/dashboard/v1/ with a POST HTTP request via fsockopen or CURL?"

    Curl Version is:
    curl 7.29.0 (x86_64-redhat-linux-gnu) libcurl/7.29.0 NSS/3.21.3 Basic ECC zlib/1.2.7 libidn/1.28 libssh2/1.4.3
    Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp scp sftp smtp smtps telnet tftp
    Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz unix-sockets

    allow_url_fopen is enabled.

    So in theory it should all be fine and the servers are mine.

    Regards
    David

  • Nithin
    • Support Wizard

    Hi Jaxom,

    our server had a problem connecting to WPMU DEV: "cURL error 6: Could not resolve host: premium.wpmudev.org; Name or service not known". Please try again.
    If this problem continues, please contact your host with this error message and ask:
    "Is php on my server properly configured to be able to contact https://premium.wpmudev.org/api/dashboard/v1/ with a POST HTTP request via fsockopen or CURL?"

    Thank you for describing the error, and making it clear, the issue isn't not related to outdated cURL.

    Could you please check whether there is firewall that's blocking the connection to the hub, if yes, would recommend you to whitelist the following IPs, and then see whether it works fine:

    66.135.60.59
    66.135.49.214
    66.135.60.64
    104.236.238.22
    104.236.50.140

    If you still have issues, please enable support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

    • Jaxom
      • Dragon Rider

      I have added the IP's to the CSF ignore, the LFD Ignore, added your FQD to lfd dynamic DNS.
      I am still not able to connect and I can't give you remote access as I can't login to be able to enable the direct access through the plugin.

      Giving you access to the site isn't going to solve the issue as it is the same on all our sites.
      This means it is a server issue, but I can't think of what else I can do as I have white listed all the IP's and your FDQ.

      What port does your system use?

  • Rupok
    • Support Ninja

    Hi Jaxom,

    Glad to see that your issue is resolved finally and thanks for sharing the workaround which did the trick. It might help others having similar type of issues in the future.

    Please let us know if you have any further query. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Denitsa
    • WordPress Warrior

    Hey there Jaxom,
    I hope you're having a beautiful day!

    This looks like a DNS failure on your server. Such situation might occur if your server has incorrect DNS settings, and thus it cannot find our IP address properly. You should therefore address your host regarding this one.

    Keep us posted on the results!

    Cheers,
    Denitsa

  • Jaxom
    • Dragon Rider

    Hi Denista
    We are the host! It pings all your IP's fine and it's now working again.
    It does have an issue with your FQD though and our DNS settings are fine.
    Plus your IP's are white listed and your FQD is also white listed so it's not a firewall problem either.

    Regards

    David

    • Jaxom
      • Dragon Rider

      Hi Denista

      This is the results of an nslookup from NS Lookup
      [&*^%dragon ~]# nslookup wpmudev.org
      Server: 127.0.0.0
      Address: 127.0.0.0
      Non-authoritative answer:
      Name: wpmudev.org
      Address: 66.135.49.214

      This was the result of a ping when I reopened the ticket.
      ping -c4 wpmudev.org
      ping: wpmudev.org: Name or service not known

      This is the result now and we have done nothing to the server in the interim.
      ping -c4 wpmudev.org
      PING wpmudev.org (66.135.49.214) 56(84) bytes of data.
      64 bytes from premium.wpmudev.org (66.135.49.214): icmp_seq=1 ttl=57 time=127 ms
      64 bytes from premium.wpmudev.org (66.135.49.214): icmp_seq=2 ttl=57 time=124 ms
      64 bytes from premium.wpmudev.org (66.135.49.214): icmp_seq=3 ttl=57 time=124 ms
      64 bytes from premium.wpmudev.org (66.135.49.214): icmp_seq=4 ttl=57 time=124 ms
      --- wpmudev.org ping statistics ---
      4 packets transmitted, 4 received, 0% packet loss, time 3004ms
      rtt min/avg/max/mdev = 124.308/125.388/127.892/1.495 ms

      So I would be inclined to say it is an API issue not a DNS issue.

      Regards

      David

  • Denitsa
    • WordPress Warrior

    Hello again Jaxom,

    This is a very strange issue here, usually, when one can't access a certain FQDN but is able to ping the IP it's the DNS settings that are at fault.

    Are you also able to try a Google DNS Server just to be on the safe side? Look for the Google Public DNS IP addresses here:
    https://developers.google.com/speed/public-dns/docs/using

    Could you also try disabling IPv6 if you have that enabled?

    Keep us posted!

    Cheers,
    Denitsa

  • Jaxom
    • Dragon Rider

    Hi Denitsa.

    In regards to the error - I did say your API.

    [Mon Feb 06 12:59:59.717697 2017] [lsapi:notice] [pid 980818:tid 140460865615616] [client 185..0.0.0:50459] [host londondrivewaycleaningservices.co.uk] Backend log: [WPMUDEV API Error] 4.3 | cURL error 6: Could not resolve host: premium.wpmudev.org ((unknown URL) [500])

    • Jaxom
      • Dragon Rider

      Yes I can ping google.com

      ping -c4 google.com
      PING google.com (108.177.15.101) 56(84) bytes of data.
      64 bytes from wr-in-f101.1e100.net (108.177.15.101): icmp_seq=1 ttl=50 time=7.01 ms
      64 bytes from wr-in-f101.1e100.net (108.177.15.101): icmp_seq=2 ttl=50 time=7.06 ms
      64 bytes from wr-in-f101.1e100.net (108.177.15.101): icmp_seq=3 ttl=50 time=7.02 ms
      64 bytes from wr-in-f101.1e100.net (108.177.15.101): icmp_seq=4 ttl=50 time=7.05 ms

      --- google.com ping statistics ---
      4 packets transmitted, 4 received, 0% packet loss, time 3003ms
      rtt min/avg/max/mdev = 7.018/7.039/7.066/0.086 ms

  • Jaxom
    • Dragon Rider

    Hi Denitsa
    I don't see how changing my ISP's IP to google dns is going to help a server issue.

    Our DNS and Name-servers work fine, all our clients websites are fine and so is our WHMCS billing system and our PayPal payment system, all of these use cURL.

  • Rupok
    • Support Ninja

    Hi Jaxom,

    So sorry for the inconvenience and for the confusion. Most probably our authoritative DNS servers were having trouble and was failing in resolving. And your non-authoritative DNS cached that response. That's why Denitsa suggested you to change your server DNS. Obviously flushing client resolver DNS cache could also help in this situation. But when you flush cache on your non-authoritative DNS and still get the non-resolving error, that means the authoritative DNS is having trouble in resolving.

    However, I believe it's working fine for you now. Can you please confirm?

    If this ever happens again, please wait for a while and try clearing client resolver DNS cache and check. I believe, that will resolve the issue. If you still get this issue after waiting and flushing DNS cache, please let us know. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.