HUB: The update of the site do not progress

Hi!

I've got a problem as I've been changing my WP manage/ backup systems to your native ones (HUB, Snap Pro).

When launching from the HUB the update of the site do not progress from showing "Updating... (0/10)", alternate cron at wpconfig do not help.

I can not disable live site security (iThemes security and Sucuri Scan) as there is also site wide https-redirects on.

Can you see from your logs what was problem with hub updating?

  • Niko Paulanne

    Error log near time of the last attempt of updating:
    [Mon Jan 30 12:40:16 2017] [error] [client 91.156.58.171] ModSecurity: Warning. Operator LT matched 20 at TX:inbound_anomaly_score. [file "/usr/local/apache2/conf/modsecurity/base_rules/modsecurity_crs_60_correlation.conf"] [line "32"] [msg "Inbound Anomaly Score (Total Inbound Score: 2, SQLi=, XSS=): Pragma Header requires Cache-Control Header for HTTP/1.1 requests."] [hostname "www.yhdistyskonsultointi.fi"] [uri "/wp-content/themes/themify-corporate/skins/black/style.css"] [unique_id "WI8mIAoAPqAAAFrvffEAAAS8"]
    [Mon Jan 30 13:06:49 2017] [error] [client 107.178.195.202] ModSecurity: Warning. Operator LT matched 20 at TX:inbound_anomaly_score. [file "/usr/local/apache2/conf/modsecurity/base_rules/modsecurity_crs_60_correlation.conf"] [line "32"] [msg "Inbound Anomaly Score (Total Inbound Score: 2, SQLi=, XSS=): Pragma Header requires Cache-Control Header for HTTP/1.1 requests."] [hostname "www.yhdistyskonsultointi.fi"] [uri "/index.php"] [unique_id "WI8sVwoAPqAAAGbKOXgAAAQh"]
    [Mon Jan 30 14:02:41 2017] [error] [client 207.46.13.253] ModSecurity: Warning. Operator LT matched 20 at TX:inbound_anomaly_score. [file "/usr/local/apache2/conf/modsecurity/base_rules/modsecurity_crs_60_correlation.conf"] [line "32"] [msg "Inbound Anomaly Score (Total Inbound Score: 2, SQLi=, XSS=): Pragma Header requires Cache-Control Header for HTTP/1.1 requests."] [hostname "www.yhdistyskonsultointi.fi"] [uri "/index.php"] [unique_id "WI85bwoAUlwAAHO2bSIAAAQ4"]
    [Mon Jan 30 14:02:43 2017] [error] [client 207.46.13.253] ModSecurity: Warning. Operator LT matched 20 at TX:inbound_anomaly_score. [file "/usr/local/apache2/conf/modsecurity/base_rules/modsecurity_crs_60_correlation.conf"] [line "32"] [msg "Inbound Anomaly Score (Total Inbound Score: 2, SQLi=, XSS=): Pragma Header requires Cache-Control Header for HTTP/1.1 requests."] [hostname "www.yhdistyskonsultointi.fi"] [uri "/index.php"] [unique_id "WI85cwoAUlwAAHO2bVcAAAQv"]

  • Niko Paulanne

    Hi!

    OK. Updated. No avail, the counter starts to move 1...12/12 but every update fails. I have virtually 3 same sites with different domains and noticed something really strange before those 3 (yhdistyskonsultointi, tonttikuvaus, pienyrityskonsultit) sites:

    Accidently updated my different kind of MU site (*.hosts.kuvausretket.fi) and it updated slowly and I hit cancel.

    Tried to update http://www.pienyrityskonsultit.fi -site without first updating WPMU Dash and update started slowly go through and then update stopped suddenly. I suppose by looking plugins the update went ahead until it did update the WPMU Dash and now the update do not work again. Bummer.

    What the heck is going on?

  • Predrag Dubajic

    Hi Niko,

    This is really strange and the issue seems to be related to Mod Security blocking the the incoming connections to your site but I never seen reports like this before.

    I have pinged our developers to check this out and see if they have any idea about the cause of this.
    In the meantime could you try disabling Mod Security and perform the update after that so we could check if that's indeed the cause here?
    You should be able to disable Mod Security directly from your cPanel, or you can try adding this to .htaccess file:

    <IfModule mod_security.c>
      SecFilterEngine Off
      SecFilterScanPOST Off
    </IfModule>

    Best regards,
    Predrag

  • Niko Paulanne

    OK, I've now disabled "Firewall" setting from host panel which I believe just adds firewall module mod_security on on the NGINX of Apache on the OVH shared hosting.

    I've also added suggested .htaccess if condition, which I believe shared hosting system just might ignore altogether (I would do that kind of parser if I would do shared hosting).

    Just FYI:
    "iThemes sync" can update just fine with or without the "Firewall" the shared hosting install from their managed site panel on their system.

    Please, I would very much like to move my sites away from the iThemes sync to your WP manager, so could you resolve this and I can move on with the other sites too.

  • Predrag Dubajic

    Hi Niko,

    After my previous response I have notified our developers about the issue and there were some changes to the HUB that could have been a possible fix for this, sorry I didn't update you about that.

    Can you tell us if there are any changes in server logs now so we can see if the same errors are still there after HUB changes or there's something else going on here?

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Niko,

    I've checked some logs related to your site on our end and they seem to confirm that The Hub is being blocked on your site's/server's end. Basically, the calls made by The Hub are rejected.

    The Hub doesn't transmit plugin/theme files to your end but it still needs to connect to your site in order to be able to initiate updates. I can see in the previous posts that you tried to disable firewall but I'm not sure if this changed anything in the end or not. Did it work with firewall disabled?

    Regardless whether it did or not, could you please try white-listing following IP "everywhere" where it's possible (I mean all the plugins that might possibly be performing IP bans, firewall on the server etc):

    66.135.49.214

    See if that helps, please. It would also be great if you could review server logs again against any connection attempts from this specific IP address. Let me know please if you found anything.

    Kind regards,
    Adam