Hub Website Reports + Updates

The monthly reports have no purpose as all the say is all is OK or updated. ie. one liners.

For each month they should list everything that changes on the site over that time period to be of any use? Listing the changes will also inform clients of how important and how much does go on behind the scenes. With one off notifications you do get the list of say - plugins that require updates or were updated or could not be updated.

Premium Plugins are not updating most of the time in the Hub.

Regards
Peter

  • Predrag Dubajic

    Hi Peter,

    Hope you're doing well.

    We had some issues with missing data in reports and we release a patch for that yesterday, did you had any reports created today that was still missing information about which plugins were updated?

    Premium Plugins are not updating most of the time in the Hub.

    Could you give us some more info about this, which premium plugins are you having issues with?
    Are you having these issues only via HUB updates or are you using Automate and experience the same issue there?
    You mentioned that it doesn't work most of the time, so it does work sometimes?
    Could you elaborate this a bit more as well, are you saying that if you try running update process in HUB multiple times in a row it will eventually update your plugins?

    Best regards,
    Predrag

  • Peter

    Hi Predrag,

    Good to hear about the patch. I have set the reports on two accounts to monthly. The last ones came in about a week ago so I haven't seen the changes. I will look out for those.

    I have had patchy results with premium plugins. It currently looks like 1 in 4 attempts do update. Premium plugins Like Backup Buddy, Gravity Forms, WP Rocket and sometimes JetPack. There are more but generally its the premium plugins.

    I have another service I am testing 'MainWP' and have no issues with premium plugin updates.

    The problems are the same with Automated or manual updates.

    Can you tell me if having these connections reduces site performance and load times and or takes up server resources?

    Regards

    Peter

    PS. Tried replying to the email that came through but had a failed send report come back?

  • Adam Czajczyk

    Hello Peter

    I have set the reports on two accounts to monthly. The last ones came in about a week ago so I haven't seen the changes. I will look out for those.

    Let us know if these reports are now fine for you or not, please. You can "speed up" checking that, if you want, by simply scheduling an additional report e.g. daily - just for testing :slight_smile:

    I have had patchy results with premium plugins. It currently looks like 1 in 4 attempts do update. Premium plugins Like Backup Buddy, Gravity Forms, WP Rocket and sometimes JetPack. There are more but generally its the premium plugins. (...)

    Unfortunately, I can't see logs for The Hub updates performed "manually" by you so I could only check automate logs. For the site that you assigned to this ticket, I only found a failed update on 2018-04-14 for Gravity Forms Campaign Monitor plugin. The error log for that update stated that there was attempt to update the plugin, which return information that the plugin actually is already in the most recent version and as a result after three attempts automatic updates for the plugins were disabled (they are disabled if they fail 3 times in a row).

    There are traces of WP Rocket, JetPack and other plugins being updated but with success. I did, however, notice that there's MainWP on that same site installed (you mentioned it being used on other site). Is it active there and performing automatic updates as well? Have you tried to disable it and see if The Hub/Automate updates are going fine then?

    Also, would you be able to tell me when (around) have you tried to manually update plugins via The Hub with those premium plugins updates failing? I'm asking about that because, as I explained earlier, from here I can only see logs for Automate updates and I'd like to ask our sysadmins to dig into logs more to see if they can find more information on our end :slight_smile:

    Can you tell me if having these connections reduces site performance and load times and or takes up server resources?

    They shouldn't reduce performance significantly or take too much resources. The Hub only "gives commands" to your site (and fetches e.g. feedback from it), for example saying it to perform update - it's not that the updated plugin is being downloaded to our servers, then uploaded to yours etc (so The Hub/Automate update shouldn't take noticeably more resources than any other update performed "from inside your site").

    Best regards,
    Adam

  • Peter

    Hi Adam,

    I have been monitoring the reports and can verify that in most cases they are working. Premium plugin and theme updates is still a bit hit and miss with some requiring logging into the site and manually updating.

    One site hosting on WP Engine wont allow reports to show updates. Updating plugins is about the same as on other servers.

    Thanks again. Ill keep tracking and start listing plugins with update issues.

    Regards
    Peter

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.