Hummingbird 0/100 Score?!?!?!

Hello,

I switched themes today and decided to try Smush Pro again. I suppose I should've known better, since last time it corrupted my theme files.

Anyway, I ran the Smush Pro plugin and now I'm getting a 0/100 score from Hummingbird. I have no idea what to do to fix this. I'm also getting a 0/100 Optimization score on Google PSI for desktop (although mobile is fine).

How the heck do I fix this?!

  • Adam Czajczyk

    Hello Nicole

    I hope you're well today!

    I accessed and checked your site (I made no changes there whatsoever so far) and I can see that you're using both Hummingbird and Smush Pro there, while the site is hosted on WPEngine. That's all fine but did you adjust Hummingbird configuration after changing theme?

    When a theme is changed, a lot of CSS/JS assets that were loaded before might be changed so the Asset Optimization in Hummingbird should be configured again. Also WPEngine is caching the site and while Hummingbird also has cache enabled, all these caches should be cleared. So the process would be:

    - clear WPEngine and HB cache
    - re-configure/adjust Asset Optimization settings
    - clear those caches again
    - only after that run a Performance Test again.

    Did you do it this way or did you just "switch theme"? I just want to make sure because if you didn't take these steps, the Hummingbird report may actually be "false" and the Page Speed results might also be affected directly.

    Assuming that all these steps were taken, the "Optimize images" score (currently reporting 0 score) is listing image files that are causing this - once you click on "Improve" button there. These images might have been already optimized previously but changing a theme usually also means that the image dimensions on site (in posts/pages) are different than they were with a previous theme.

    That's why these images are detected again. You'd notice that they are all marked as "Compress and Resize" and that usually means that the "resize" part is the issue here.

    There's currently a "Detect and show incorrectly sized images" option in Smush (that you can enable on "Smush Pro -> Bulk Smush" page).

    Once it's enabled, it adds a panel on a front-end that shows all the incorrectly sized images on a given page (the one that you're viewing) so you would want to go through the pages of your site and check those images to resize them so they'd be matching their containers in size.

    After that, clear all the caches again and run the test again and it should cause a significant increase in the score.

    Kind regards,
    Adam

  • Predrag Dubajic

    Hi Nicole,

    I had run two performance tests on your site and the first one did show 0 score indeed but the second one updated properly and your overall score is now 95, the same as on Google Page speed test.
    And image optimize warnings are completely gone.
    So it seems that there was just some caching serving the old images that caused the reports and you should be good to go now.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.