Hummingbird 1.5.4 Issues with combining / minify

After updating Hummingbird to the latest version there seems to be a problem after re-cashing the files in humming bird (“RE-CHECK FILES” Button on the minify page).

As i made some change to one of the CSS files i had to reload the files so the css was updated in the combined/minified version. I did this by clicking the button in the minify page and it came up with a notice that the files had been recached.

At first the files where not getting combined nor minified. after about 10 minutes (during the time of opening this ticket) the files suddenly where minified and combined. before updating changes where published instantly.

  • Bottle Post Media S.L.U.
    • Flash Drive

    Hi, Thanks for letting us know. My collegue in charge of this mail box did not forward this mail to me, the new version seems to be working well only we notice one more thing that is going wrong. the minifier does not take in account if a website is running in https or http causing in some of our websites that have a SSL installed to get mixed content warnings when there are images and fond files included via url() for example example the dash icons have this problem

  • Dimitris
    • Support Star

    Hey there Bottle Post Media S.L.U.,

    hope you’re doing good today! :slight_smile:

    I just inspected couple of testing sites using a secured protocol and after activating HB’s Minification, I couldn’t see any mixed-content issues, also wp-admin dashicons are being displayed correctly.

    This may also have to do with the actual way you use to surpass these mixed-content errors and force the https:// protocol. Which is that? Please advise! :slight_smile:

    Could you also please grant us with temporary support access to this website, in order to have a better look? Here’s how to do so via WPMUDEV Dashboard plugin (no need to share credentials):

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Just let us know here in your next reply that access has been granted, as we don’t get any notifications about it.

    Warm regards,

    Dimitris

  • Bottle Post Media S.L.U.
    • Flash Drive

    Hello Dimitris,

    We are doing fine, we are strictly enforcing https due to the information on the site being sensitive. the problem occurs in the following domain https://spanishprofessionals.es/ additionally i have to say we have installed the SSL after installing the website thus we changed the site url from http to https maybe this causes the links to be added as http instead of https (they are all relative links that are converted to a absolute link)

  • Adam Czajczyk
    • Support Gorilla

    Hello Bottle Post Media S.L.U.,

    I checked your site and while there’s no “mixed content” issue on the homepage, I can see it on other pages. The files that are blocked are some font files that are native to WP but it seems that your current theme is using them two.

    It looks like those files are used in some of the theme’s JS files. Since they are minified, it’s difficult to target precisely those JS files but the source code suggests this:

    /**handles:meshjobs_bootstrap,meshjobs_modernizr,meshjobs_tools**/

    On your site all of the theme JS files seem to be moved to the footer so that might be resulting in JS script not being able to properly recognize the protocol. Try switching off “Footer” option in minification setting for those JS files that you think might be relevant to that line quoted above, I think that should help.

    Let me know if it worked for you please.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.