[Hummingbird] 500 error only on Hummingbird Pro Admin

I can get into Smush Pro and see the settings in there as well as any other plugin in my admin section of the site but Hummingbird Pro keeps throwing a 500 error. Can you tell me what might be causing this and what the fix for this is likely to be?

  • Adam Czajczyk

    Hello Mart,

    I hope you're doing fine today and thank you for your question!

    The "500 Internal Server Error" can be caused by various reasons, unfortunately it's not very well defined. In case of WordPress it's very often caused simply by available PHP memory overload.

    That being said, I'd suggest starting with following:

    - in your site's dashboard go to "WPMU DEV -> Support" page and click on "System info" button
    - in a "PHP" tab check the value of "memory_limit" to confirm that it's 256M or more
    - assuming that above is true, switch to "WordPress" tab and scroll it all the way down
    - check the value of "WP_MEMORY_LIMIT" (not to be confused with WP_MAX_MEMORY_LIMIT)
    - I suppose that value is currently 40M, 64M or 96M; if it's less than 256M, make this change:

    - access the site via FTP or cPanel "File Manager"
    - find and edit the "wp-config.php" file of your site
    - add this line to it, right above the /* That's all, stop editing */" line

    define('WP_MEMORY_LIMIT', '256M');

    - save the file and check the site again.

    If that doesn't solve the issue, I'll need to investigate the case closer. In such case please:

    - enable support access to the site so I could take a closer look; to do this, go to "WPMU DEV -> Support" page in your site's dashboard and click on "Grant Support Access" button there

    - add full FTP or cPanel access credentials (url/host, login, password, port number if necessary) to the text box under the green "Access active for X days" message there; this field is just a note that we (WPMU DEV official support staff) can only see after accessing your site, it is not published anywhere so it's a secure way to share such information.

    Looking forward to your response,
    Adam

  • Predrag Dubajic

    Hi Mart,

    I checked your installation but I'm afraid that I was unable to replicate this issue, I visited all the Hummingbird pages in there but they all loaded fine and I didn't see any 500 errors.

    Can you enable debug log in your wp-config.php file (located in root WP folder) by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Go to Hummingbird panel again and if you can see the error it should create a debug.log file inside your wp-content folder.
    If you can see the file then download it, change the extension to .txt and attach it here so we can see what's causing the error for you.

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Mart,

    Please don't leave any login details here because forums are public by default.
    I've seen your response just couple of minutes later and removed those but I still suggest changing your password as soon as possible.

    Can you try updating Hummingbird to latest version and see if the issue is gone after that?

    If the issue is still there you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Predrag Dubajic"
    - Site login url
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.