Hummingbird and rendering issues

How to get rid of cloudfront.net?

  • Dimitris

    Hey there Mlaure,

    hope you're doing good and thanks for reaching us! :slight_smile:

    Simply go to HummingBird -> Minification admin page, scroll down to the very end, and disable the "Store my files on the WPMU DEV CDN" option.
    Refreshing your homepage should be enough to start serving assets from your webserver instead.

    You may also have to clear/purge any other involving cache if you're still seeing cloudfront links instead.

    Hope that was some help, let me know how that goes!
    Warm regards,
    Dimitris

  • Adam Czajczyk

    Hello @mlb!

    As for server response time. If you can't get past certain timing even despite implementing caching, minification and other optimization methods, the remaining options would be:

    1) review all the plugins that you are using on the site and then:
    - remove all that are not absolutely necessary
    - try to replace some other with simpler alternatives
    - make sure that all those that are not used (e.g. are used only some times for certain manually triggered tasks) are kept inactive (disabled) when not used

    2) see if a theme could be "simplified"; I'm not aware what theme are you using but sometimes it might be justified to make an investment hire a pro that would develop a dedicated theme for you, using only core WP techniques (so it wouldn't be based on frameworks and utilize number of plugins)

    3) opt for more powerful host/server; sometimes there's literally no way to optimize server response time more than up to some point because server is not able to handle that.

    As for "render blocking resources". There might be a case when not all of them will be fully optimized but you with Hummingbird you should be able to optimize as many of them as possible. First step is to configure minification to minify as many files as possible without breaking the site. Second one is to do the same with "combine" option for all these files (also in Hummingibird's minification section). Finally, it's time to move as many of them to the footer of the site as possible. The "Position" switch on "Hummingbird -> Minification" page will let you do this.

    My advice however would be to do this as follows: instead of moving all the files to the footer at once, move one of them - on top of the list - and make sure that the site works as it should. If it does, do the same for the next file and repeat that until either you reach the end of the list (that'd be the perfect case) or until the site starts to break. If that happens, switch "Position" for the last file that you changed back to "Original" position and skip to the next one.

    Make sure though that you are making these changes with all caching options disabled. Only after this is configured, switch caching back on and see how this affected "render blocking resources" score.

    If you have any further questions, let me know please.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello Mlaure,

    This message means that the Defender plugin is trying to increase allowed PHP script execution time before it starts scan. It does attempt to do this in order to minimize the risk of scan terminating or hanging out.

    On some servers however the "set_time_limit()" function cannot be used due to strict PHP configuration (hence the "due to system policy" statement). That's actually not unusual, especially in shared hosting environments :slight_smile:

    The message however is only a warning and it shouldn't itself interfere with anything. Still though, if it turns out that the Defender scan times out you might need to increase PHP "max_execution_time" value by changing PHP settings. That can often be done via cPanel but if it's not possible, you might need to turn to your host's tech support for help.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.