Hummingbird and site speed

Hi - I installed the hummingbird trial and enabled gzip and caching and CDN but site speed is the same and in fact google pagespeed is still the same speed results and is saying that i need to 'Enable compression for the following resources to reduce their transfer size by 115.6KiB (82% reduction).'

Please advise

  • Majid

    Welcome to WPMU DEV Carl Burness !
    I hope you are doing great today :slight_smile:

    I ran a speedtest on your site and I it says that compression is enabled. However the browser cache seems to be still an issue, so make sure you have it enabled under HummingBird > Caching

    I also couldn't access the site to check the settings because Sucuru got me blocked.

    Let me know if you need further guidance :slight_smile: I will be happy to help.

    Thanks for being part of WPMU DEV
    Cheers,
    Majid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.