hummingbird and wp supercache conflict?

Hi there--are these two plugins exclusive of each other. I have been trying to add in BROWSER CACHING and am getting the following warning. I am certain our server supports this (Liquid Web hosting, formerly RackSpace)
Browser Caching is not working properly:
- Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)

    Carlos

    and, sorry, meant to say that the rules ARE in the htaccess file

    ExpiresActive On
    ExpiresDefault A0

    <FilesMatch "\.(txt|xml|js)$">
    ExpiresDefault A1382400
    </FilesMatch>

    <FilesMatch "\.(css)$">
    ExpiresDefault A172800
    </FilesMatch>

    <FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$">
    ExpiresDefault A2592000
    </FilesMatch>

    <FilesMatch "\.(jpg|jpeg|png|gif|swf|webp)$">
    ExpiresDefault A691200
    </FilesMatch>
    </IfModule>

    <IfModule mod_headers.c>
    <FilesMatch "\.(txt|xml|js)$">
    Header set Cache-Control "max-age=1382400"
    </FilesMatch>

    <FilesMatch "\.(css)$">
    Header set Cache-Control "max-age=172800"
    </FilesMatch>

    <FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$">
    Header set Cache-Control "max-age=2592000"
    </FilesMatch>

    <FilesMatch "\.(jpg|jpeg|png|gif|swf|webp)$">
    Header set Cache-Control "max-age=691200"
    </FilesMatch>
    </IfModule>

    Carlos

    here is a copy of my full htaccess

    php_value upload_max_filesize 32M
    php_value post_max_size 18M
    php_value max_execution_time 180
    php_value max_input_time 180
    php_value max_input_vars 4000
    # BEGIN WP-HUMMINGBIRD-CACHING
    
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault A0
    
    <FilesMatch "\.(txt|xml|js)$">
    ExpiresDefault A1382400
    </FilesMatch>
    
    <FilesMatch "\.(css)$">
    ExpiresDefault A172800
    </FilesMatch>
    
    <FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$">
    ExpiresDefault A2592000
    </FilesMatch>
    
    <FilesMatch "\.(jpg|jpeg|png|gif|swf|webp)$">
    ExpiresDefault A691200
    </FilesMatch>
    </IfModule>
    
    <IfModule mod_headers.c>
      <FilesMatch "\.(txt|xml|js)$">
       Header set Cache-Control "max-age=1382400"
      </FilesMatch>
    
      <FilesMatch "\.(css)$">
       Header set Cache-Control "max-age=172800"
      </FilesMatch>
    
      <FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac)$">
       Header set Cache-Control "max-age=2592000"
      </FilesMatch>
    
      <FilesMatch "\.(jpg|jpeg|png|gif|swf|webp)$">
       Header set Cache-Control "max-age=691200"
      </FilesMatch>
    </IfModule>
    # END WP-HUMMINGBIRD-CACHING
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # BEGIN WP-HUMMINGBIRD-GZIP
    
    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            <IfModule mod_headers.c>
                SetEnvIfNoCase ^(Accept-EncodXng|X-cept-Encoding|X{15}|~{15}|-{15})$ ^((gzip|deflate)\s*,?\s*)+|[X~-]{4,13}$ HAVE_Accept-Encoding
                RequestHeader append Accept-Encoding "gzip,deflate" env=HAVE_Accept-Encoding
            </IfModule>
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE "application/atom+xml" \
                                          "application/javascript" \
                                          "application/json" \
                                          "application/ld+json" \
                                          "application/manifest+json" \
                                          "application/rdf+xml" \
                                          "application/rss+xml" \
                                          "application/schema+json" \
                                          "application/vnd.geo+json" \
                                          "application/vnd.ms-fontobject" \
                                          "application/x-font-ttf" \
                                          "application/x-javascript" \
                                          "application/x-web-app-manifest+json" \
                                          "application/xhtml+xml" \
                                          "application/xml" \
                                          "font/eot" \
                                          "font/opentype" \
                                          "image/bmp" \
                                          "image/svg+xml" \
                                          "image/vnd.microsoft.icon" \
                                          "image/x-icon" \
                                          "text/cache-manifest" \
                                          "text/css" \
                                          "text/html" \
                                          "text/javascript" \
                                          "text/plain" \
                                          "text/vcard" \
                                          "text/vnd.rim.location.xloc" \
                                          "text/vtt" \
                                          "text/x-component" \
                                          "text/x-cross-domain-policy" \
                                          "text/xml"
    
        </IfModule>
        <IfModule mod_mime.c>
            AddEncoding gzip              svgz
        </IfModule>
    
    </IfModule>
    # END WP-HUMMINGBIRD-GZIP
    Predrag Dubajic

    Hi Carlos,

    .htaccess rules look good so that shouldn't be the issue.

    Also, I use HB Browser Caching with WP Super Cache on one of my installations so that shouldn't be the cause either.

    It's most likely that your host supports "expires" module but perhaps it's disabled on their servers by default so it's worth checking with them to be sure that this module is indeed enabled.

    While doing this it's also worth checking if they allow browser caching rules to be made via .htaccess or they have some predefined values on their servers.

    Best regards,
    Predrag