[Hummingbird] Asset Optimization not compressing

I've had the asset optimization set to compress my assets for a while now, but nothing has happened. Am I supposed to do anything to trigger these compressions?

  • Nahid

    Hey Lindsay !
    Hope you are doing well today!

    I took a look into your site and can see the issue that you're encountering. It is not an expected behaviour and we cannot say what might be causing this just yet without some troubleshooting tests. First of all, could you try running a plugin/theme conflict test just to make sure no other plugin(s)/the theme is/are conflicting with Hummingbird and causing the issue? I can see Automtimize is already optimizing the resources and caching them. We'd not recommend using multiple plugins which are designed to do the same thing as they'll likely conflict. The basic concept of the plugin/theme conflict test is to temporarily disable all the plugins except Hummingbird Pro (and WPMU DEV Dashboard), switch to a default WordPress theme and see if the issue still persists. If it doesn't, please try activating the plugins followed by the theme to see activating which brings back the issue. This handy flowchart can help you run a plugin/theme conflict test. If the issue still persist after disabling everything, please report back to us so we can carry on with some further troubleshooting steps.

    Note: We'd strongly recommend you to back the entire site up before the test and disable all caching mechanisms to receive instant results. Please also note that Hummingbird's Asset Optimization waits for a visitor to visit your homepage after the changes have been made in order for the changes to take effect.

    Hope this helps. We'll be looking forward to hearing back from you. Thanks!

    Kind regards,
    Nahid