Hummingbird Asset Optimization Not Working

Asset Optimization is not running in my site. I created a staging site and disabled all plugins and it doesn't work too. furthermore, one of our other sites is set up the same way, and hummingbird runs perfectly

  • Luís
    • Support

    Hi Fuel Travel ,

    Hope you're doing well!

    During our live chat, the Asset optimization worked on the staging site with almost the plugins disabled, but stills not working on your production site.

    I also checked the error logs, but nothing relevant was saved, so at this point, and based on the above, I will suggest you to start enabling the plugins on your staging site to check if the Asset Optimization still works, this to check if any plugin is conflicting.

    Cheers, Luís

  • Nithin
    • Support Wizard

    Hi Fuel Travel,

    What Luis mentioned is that, when tested in your staging with all plugins activated, Asset optimization didn't work. But when all the plugins were disabled it worked in staging.

    So, if you could activate the plugins one-by-one, and check the frontend, and see which exact plugin once enabled is making Asset Optimization to not run in your staging site, then it would give a better idea on what could be done to troubleshoot this issue further.

    Please let us know how that goes. Have a great weekend ahead. :slight_smile:

    Regards,
    Nithin

  • Fuel Travel
    • New Recruit

    Hi, Nithin.
    He did not test it with all the plugins active.
    If I remember right he tried with everything off (Except for Titan and ACF), it didn't work, and then he tried again after checking the logs and it worked.

    It turned out that I enabled all the plugins and it was still working.
    So, I cloned the installation from production to staging again. The problem was back.
    I disabled all the plugins (Except for Titan and ACF) and then enabled them - Asset Optimization was still not running.

    Finally I tried turning all the plugins off (Except for Titan and ACF), initializing Asset Optimization (only letting it go to 3%) then canceling it. After that I turned all the plugins on again and started Asset Optimization and it ran fine (and continues to run fine). I performed these last few steps on production and got the same result (working fine).

    I have not looked into Hummingbird's code but I imagine that there is some process that only runs before the first-ever Asset Optimization check, and this seems to have a conflict with one of the sits's plugins.

    Any idea which process might be getting interrupted? If so, it might give me clues about where the conflict is. Unfortunately, I don't have more time to toggle plugins on and off for this site (especially since it is currently working).

  • Nithin
    • Support Wizard

    Hi Fuel Travel,

    Thanks for explaining further. Seems like the login credentials shared to us is no longer working for your staging, nor I was able to log in via the support access.

    I have not looked into Hummingbird's code but I imagine that there is some process that only runs before the first-ever Asset Optimization check, and this seems to have a conflict with one of the sits's plugins.

    Yes, what Asset Optimization checks are the assets hooked into WordPress, however disabling all the plugins should have made the conflict test work, which didn't work in your test case.

    For the info, checking with Luis, seems like he also disabled ACF plugin, only kept the Titan Framework plugin enabled. Maybe you could double check regarding ACF too.

    Any idea which process might be getting interrupted? If so, it might give me clues about where the conflict is. Unfortunately, I don't have more time to toggle plugins on and off for this site (especially since it is currently working).

    I'm afraid, there isn't an easy way to check what could be causing this in the back-end without troubleshooting the site further. Could notice that you meant that it's working fine now. If you are still able to replicate the issue again, and want us to troubleshoot the issue further.

    Could you please correct the WP Admin login shared, or enable support access so that we could give a closer look?

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.