Hummingbird browser cache not working

I added the necessary codes inside nginx config file but on the Hummingbird side, browser caching still not works. How can I solve this?

  • James Morris
    • WordPress Enthusiast

    Hello Bjorn

    I hope you are well today.

    The issue you are experiencing is a known bug, but is one we have a hotfix available for. We will be releasing a full version soon that includes this hotfix. If it is critical that you have this before the formal release, you can apply the attached hotfix files to your site by performing the following steps:

    - Please make a backup of your site before applying this patch!
    - Download the attached zip file and extract the contents in a convenient place
    - Login to your server via FTP and navigate to ~/wp-content/plugins/wp-hummingbird/
    - Upload the contents of the wp-hummingbird folder you extracted to your site, overwriting the originals
    - Navigate to WP Admin -> Hummingbird -> Caching -> Browser Caching, deactivate caching then re-activate

    This should resolve the issue for you. Let us know if you have any further issues.

    Best regards,

    James Morris

  • Bjorn
    • Site Builder, Child of Zeus

    Hi James
    Sorry for the late reply, I have now downloaded the file and uploaded the contents to the wp-hummingbird.
    But I still get the same result ( 4 of your cache types don’t meet the recommended expiry period of 8+ days. Configure browser caching here.)

    nginx.conf

    user kalligo; worker_processes auto; pid /var/run/nginx.pid; events {
        worker_connections 3024;
        multi_accept on;
        use epoll;
    }
    worker_rlimit_nofile 40000; http {
        fastcgi_cache_path /usr/share/nginx/cache/fcgi levels=1:2 keys_zone=microcache:10m max_size=1024m inactive=1h;
        client_body_buffer_size 10K;
        client_header_buffer_size 1k;
        client_max_body_size 3000m;
        large_client_header_buffers 8 128k;
        client_body_timeout 12;
        client_header_timeout 12;
        send_timeout 10;
        include /etc/nginx/mime.types;
        default_type application/octet-stream;
        log_format main '$remote_addr - $remote_user [$time_local] "$host" "$request" '
              '$status $body_bytes_sent "$http_referer" '
              '"$http_user_agent" "$http_x_forwarded_for"';
        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;
        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 65;
    
        types_hash_max_size 2048;
        server_tokens off;
        gzip on;
        gzip_disable "MSIE [1-6]\.(?!.*SV1)";
        gzip_proxied expired no-cache no-store private auth;
        gzip_comp_level 5;
        gzip_min_length 256;
        # gzip_buffers 16 8k; gzip_http_version 1.1;
    
        # Compress output of these MIME-types
        gzip_types
        application/atom+xml
        application/javascript
        application/json
        application/rss+xml
        application/vnd.ms-fontobject
        application/x-font-ttf
        application/x-font-opentype
        application/x-font-truetype
        application/x-javascript
        application/x-web-app-manifest+json
        application/xhtml+xml
        application/xml
        font/eot
        font/opentype
        font/otf
        image/svg+xml
        image/x-icon
        image/vnd.microsoft.icon
        text/css
        text/plain
        text/javascript
        text/x-component;
        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
        server {
    		location ~* \.(txt|xml|js)$ {
    			expires 8d;
    		}
    		location ~* \.(css)$ {
    			expires 8d;
    		}
    		location ~* \.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav|mp4|m4v|ogg|webm|aac|eot|ttf|otf|woff|svg)$ {
    			expires 8d;
    		}
    		location ~* \.(jpg|jpeg|png|gif|swf|webp)$ {
    			expires 8d;
    		}
            if ($request_method !~ ^(GET|HEAD|POST)$ )
    
    		{
                return 444;
            }
        }
    }

    Site is https://test.cimco.se

  • Bjorn
    • Site Builder, Child of Zeus

    Hi Kasia
    I have updated to to latest version and the problem is the same :slight_frown:
    ( 4 of your cache types don’t meet the recommended expiry period of 8+ days. Configure browser caching here.)
    Anything else I can do?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.