Hummingbird Browser Caching and e-commerce

In the past we have used WP Cache but had problems with the shopping cart in our e-commerce plugins. Does the browser caching in Hummingbird affect shopping carts and such, and if so, is there an exclusion that I could make to take advantage of at least some of the caching effect? Thank you.

  • Rupok

    Hi Joni,

    Thanks for asking. I've enabled Hummingbird Browser Caching in my test site and then checked MarketPress shopping cart. I didn't face any issue in adding items to cart and checkout. So I don't think it will conflict in your site too. And I've also searched in our forums. Didn't find anyone else complaining about any issue with Hummingbird Browser Caching and MarketPress or WooCommerce cart/checkout functionality. So I think, you can enable Browser Caching on your site.

    Can you please tell us which e-commerce plugin you are using on your site? And Please let us know if you face any issue with Hummingbird Browser Caching and cart functionality on your site. We will be glad to help further.

    Have a nice day. Cheers!
    Rupok

  • Nithin

    Hi Joni,

    Hope you are doing good today. :slight_smile:

    Sorry to know that you are having issues with the plugin, it seems like the support access is disabled at the moment so I wasn't able to check the https mixed content issue. I suppose, you changed your website from HTTP to HTTPS, and maybe Hummingbird cache was old, and was calling some files over http protocol based on that. You could try re-checking the minified files, by clicking the RE-CHECK FILES button, located under Hummingbird > Minification.

    If that's not the case, you could try excluding the file having issue from being minified, by disabling the combine, and minify option, as shown in the example screenshot below:

    Also with the plugin activated, it totally messes up the display of the website - the slideshow on the home page displays all of the pictures on top of all of the posts... displays the Skip Navigation... I think that this is not for us.

    This could be because of minification, minification entirely depends upon on how your theme honours the minification settings. If you find that your display beaks in certain page, you'll have to move the files causing the issue to the header/footer, and then check whether the page works fine. You can make these changes, under Hummingbird > Minification page.

    I would be able to give you a better idea regarding both the issues, if I could check your website with Hummingbird enabled. If you are looking to troubleshoot this issue further, you can grant support access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.