[Hummingbird] Browser caching doesn't show expiry options

In Hummingbird, I had the Browser Caching configured to the expiry period of 8 days as recommended. After the recent Hummingbird update, the browser caching expiry are saying 1 second now. I had Cloudflare connected, but no expiry options are showing up in the settings. Please advice.