Hummingbird Browser Caching Error Message

Hello,

I have activated browser caching in hummingbird and have the following error:

Browser Caching is not working properly:

    - Your server may not have the "expires" module enabled (mod_expires for Apache, ngx_http_headers_module for NGINX)
    - Another plugin may be interfering with the configuration

If re-checking and restarting does not resolve, please check with your host or open a support ticket with us.

Although this error is present I can see that expiry caching is being set properly on objects:

Cache-Control: max-age=2592000
Connection: keep-alive
Date: Thu, 15 Dec 2016 15:55:19 GMT
Etag: "1c0a6-543b184c97588"
<strong>Expires: Sat, 14 Jan 2017 15:55:19 GM</strong>T
Server: Apache/2.4.23 (Amazon) PHP/7.0.13
via: 1.1 5ec64d9502b4a51a283c9c8c16414219.cloudfront.net (CloudFront)
x-amz-cf-id: eOn_oVp5uT1SXLyMOe1FcUFNpsgu2reGpQLDW_D1FnqjR-3A-kB2nQ==
x-cache: RefreshHit from cloudfront

Pingdom Website Speed test returns an A (100) for the site:

I have verified that mod_expires is loaded, that the .htaccess is properly configured.

Current plugins

Akismet
Amazon Web Services
Query Strings Remover (would love this to be in hummingbird!)
WP Hummingbird
WP Offload S3 Lite (cdn.applike.me for media images)
WPMU DEV Dashboard

Infrastructure:

(2) AWS EC2 t2.micro using AWS elastic filesystem
(1) AWS RDS t2.db.micro
(1) EC2 Load balancer w/ HTTPS endpoint
Cloudfront Distrubutions (CDN and *.APPLIKE)
*.applike.me has 60s max/min ttl while setting up/testing
cdn has 3600 max/min ttl with versioning activated
Autoscaling

Would like to understand how the UI is validating mod_expires exists and if the caching/elastic filesystem could be causing the issue with the plugin reporting an error on the dashboard.