[Hummingbird] Browser Caching not happening.

It's not doing browser cache, pl,ease help. Thanks!

  • Nastia

    Hello SK

    Hope you're doing well!

    The Hummingbird applies only the right rules to the .htaccess file to enable caching. Please share here your .htaccess file, so we could have a closer look at it.

    Have you tried manually adding the rules to the .htaccess file? Please see attached screenshot:

    If after manually adding the code, the issue still persists, would you please grant access from WPMU DEV > Support so I can have a closer look?

    Please see the detailed instructions on the link below:

    Let me know when you do!

    Pls find the attached screenshot. Now, I think we might need to add some IP whitelisting for wpmudev in our AWS server. Can you help me with IPs? and also where to add in AWS.

    To solve the CORS error, please add these lines in the .htaccess file

    <IfModule mod_headers.c>
      <FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|font.css|css|js)$">
        Header set Access-Control-Allow-Origin "*"

    Let us know how it went!

    Kind regards,

  • Dimitris

    Hello SK,

    I'm really sorry for that, we could continue troubleshooting this though, as all caching-type functionalities are based on server settings actually.

    If you still want us to carry on checking this for you, please do let us deactivate W3TC and activate back HummingBird. Then send us over some server credentials to better review this. As this is public forum, you must send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question
    using this template:

    Subject: "Attn: Dimitris"
    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password/path of site in question)
    - cPanel/Plesk credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Thank you,

  • SK

    Hello Dimitris,

    I would love to use HummingBird for cache related activities on our website speaktoday.com but we really need to ensure that it will be able to handle all issues listed below... site shouldn't go down.

    http://prntscr.com/kl62g4 - I am not sure if Hummingbird can manage all this. We are using W3TC

    And, I love wpmudev for some reasons. If hummingbird works perfect for all these settings, will go ahead with my monthly subscription also as promised. Even then, I will go for monthly subscription but will be more confident with wplms if some of these plugins help improve the website functionality.

    Let me know when would you like to try hummingbird.

    Thank you,

  • Dimitris

    Hello there SK

    Appreciate the granted support access, let me reply on the requests shared in above screenshot.

    1. Combine external JS & CSS
    I'm afraid this isn't possible with Asset Optimisation in HummingBird and as far as I can see, this isn't possible with W3TC too (I could only find a "Update external files" setting in Minify options, please do correct me, if I miss something here).
    Despite that though, you can use the "defer" option for these external files, which can lead in much better performance.
    More details on Asset Optimisation options (formerly "Minification") can be found here:

    2. Parallelize Downloads Across Hostnames

    This is because web browsers are limited to the number of concurrent connections they can make to a host. This is mainly due do HTTP/1.1 in which browsers open on average 6 connections per hostname. This warning is typically seen on websites with a large number of requests. In the past, the only way to get around this limitation is to implement what they call domain sharding.
    If you are running over HTTPS with a provider that supports HTTP/2, this warning can usually be safely ignored now. With HTTP/2 multiple resources can now be loaded in parallel over a single connection.

    (source: https://kinsta.com/knowledgebase/parallelize-downloads-across-hostnames/)
    HummingBird already disables any "combine" functions when HTTP/2 is used in server, as it would lead to slower responses in user's end, doesn't provide any workaround for HTTP/1.1 servers though, as these should implement combination of assets and try to server as few files as possible.

    Hope that was some help, let us know, if further assistance is required here. :slight_smile:

    Thank you,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.